Sync app does not display app UI

I created several tables and a couple of views but data never showed up as a view on my app.
Is there a setting I’m missing out to enable?
Many thanks,
Duygu

I had a similar issue a few days ago.
This happened only with one of my table, other datas went up correctly (around 10 tables at this time).
I deleted the table that was not showing data and added it again, and that fixed my issue.
Can you try with one table, just to see if that changes something ?

1 Like

Hi @Aurelien, deleting and re-adding the table worked ok.
However, it might have been a problem with the key of that table: which was “item_id” column, a blank column in my sheet and was auto-generated by AppSheet.
When I re-added the table like you suggested, AppSheet it selected another column “item_name” by default (I guess because item_id was intentionally left blank) then the UI was visible.
I will continue using the table like this for now until I have to auto generate id’s!
Thanks a lot,
Duygu

1 Like

@donaral

Good if that worked.
However, keep in mind:

  • always have a unique ID column, with initial value expression : UNIQUEID()
    you can select this one, maybe you have a formula in your sheets on this column. If so, please have a look in the item_id column, auto-compute section, Spreadsheet formula ==> clear this area
  • item_name “looks like having unique values for AppSheet” if I understand well in your case, so that could be ok but not good practice
  • a good practice as well could be to set a name to the id column in your spreadsheet, to avoid names such as “column 2”, “column 3” and so on in the editor :stuck_out_tongue:
2 Likes