Table Main View settings? How do you choose ...

ux
(David Ames) #1

Table Main View settings?

How do you choose which column data is showing in the Table Main View?

I’ve attached screenshots of 2 of my Table Views.

The first is Table “Chart 10s”; the second is Table “Chart 5s”.

One has the column “Incr.” data showing, and the other has the column “5 MAX” data showing.

I assume there is a setting one can change to show the same column data in these main views of each table.

I’ve been searching and searching for it, but I can’t seem to find it.

Thanks!

#2

Check in UX/Views and for each view you can specific column order.

Need to do this for each View definition.

Also ck your layout setting to be “Narrow” if you want the most numbers of columns showing.

(David Ames) #3

I’m not sure I understand.

I don’t want to change the column or row order (it seems like your suggestion is allowing me only to do this).

I want to specify which column shows up in the Main View of each table.

Why is it showing “Incr.” column in one table, and “MAX 5” column in the other table?

I’ve dug down in the view settings and nothing is indicating that these should be different columns showing up in each of the table Main Views.

Both tables have the exact same columns (names and order) in the corresponding spreadsheet, so I don’t know why each view is appearing differently in these main views.

Thanks.

#4

Maybe I am missing your point, but on the same UX/view screen, you can add or delete any of the fields you want displayed in the table view, and in which order

(David Ames) #5

That may be, but how do you do this?

I don’t see any option to add a field to the table view…just options to sort rows by columns or group rows by values.

#6

See if this helps you Controlling Column Order help.appsheet.com

(David Ames) #7

Mike,

Thanks for all your help here, but this does not address the issue.

I do not want to control the order of the columns.

They already appear in the correct order.

Each table that I am referring to has the exact same column structure, and should display in the same order, which they both do already in AppSheet, in the detail view.

So I don’t have to set any manual order, since they are already showing up in the correct order, in the detail view.

What I want to do is control which column appears in the MAIN VIEW of each table.

I attached screenshots to my original post (see below).

2 columns show up in the Main Table View for each table.

Chart 10s shows column A (2 SETS OF 10 REPS) and column B (Incr.) from the Google Sheets table.

Chart 5s shows column A (2 SETS OF 5 REPS) and COLUMN I (5 MAX).

I never set any setting or sort order for these to show up in the MAIN TABLE VIEW in AppSheet.

BUT THEY SHOULD BOTH SHOW COLUMN A AND COLUMN I for each respective Google Sheets table.

HOW DO I SET THIS?

How do I get Chart 10s Table View to display Column A (2 SETS OF 10 REPS) AND Column I (10 MAX)?

MAIN TABLE VIEW OF “CHART 10s”:

(This should be Column I “10 MAX” on the right hand side, not “Incr.” which is Column B in the spreadsheet… just like the Chart 5s, below, is “5 MAX” on the right side, which is Column I in its corresponding spreadsheet.)

MAIN TABLE VIEW OF “CHART 5s”:

(David Ames) #8

OK, I think I got it now.

The column order you are talking about does NOT affect the column order in the Detail View…JUST the Table View.

I think it’s random that different columns are being displayed in the Table View when nothing is different in each table.

But I went ahead and set the Column Order as is outlined in the link you gave me, just for the Chart 10s table, and it’s showing up the way I want it to.

Thank you!