Table View Displaying Column

Hi, I got a table view form which I have been added 7 columns to display in the table view, but unfortunately it only display 5 columns.

I have tried many solution, but it can’t help. The thing that I have tried:

  1. Confirm the column - show is ticked
  2. Recreate the column
  3. Regenerate the structure

The column that added in the table view, is displayd in the detail view.

Please post a screenshot of the table view that does not show the missing columns.


1 Like

Is the view configuration shown on the left side the Resident Master view identified under the app emulator on the right side?

1 Like

Ya, the left side is the column order for the view that shown on the right side.

No, it’s not. Please post a screenshot of the entire view configuration show on the left.

1 Like

Hi Steve, thanks for helping, forget it, it really didn’t show the column, only that particular column.

Nvm, I change the view to Deck, while Deck has no issue displaying that column.

Thank you, and have a nice day.


Dear, I am still facing these problem, the table view form unable to display all the columns.

I have created three table view form, each of them retrieving data from different sheet, while all the added columns is about 6~10 columns.

I understand that the display columns might retricted with the screen size. I am access these table view via PC. One of the table view able to display all, while the other two table views is displaying 4 & 5 columns.

I am pretty sure the column setting in data, the show option is ticked.

Any clue of, what possible will making the column is not visible in the table view form?

Oh, I see. You’ve used the Group by feature. With that feature, the grouped column is removed from the display as the user drills-down. This is how the feature works; there is no way to change this behavior.

Dear Steve, thank you.

Let me understand, the column that we set under Group By option will be removed from the display, this I understand.

But the column that non-show, is not set in the group by option, eg: the “carry Forward Outstanding”, “Outstanding Interest”, and “Pay up to Month…”

FYI, I found the solution for this, I use the same view setting, and I create an additional data slice, and set the data source for this table view to the newly created slice (previously is the direct source from master table), it works now.

Any clue of why this happened? Is it some setting I did wrongly? Or it is appsheet’s bug?

The behavior you describe is very odd, and definitely not what I would expect. You may well be running afoul of a bug. Your best bet is to engage so someone can take a look at your app configuration and see what’s going on. Once the issue is resolved, I would appreciate you sharing the fix with us here in the community. I’m very curious!

I think I may have the same problem. Here’s my situation. First, the table settings:

pos2 is a simple virtual column that merely copies pos. pos2 is displayed but not pos:

pos is in the slice:

Screen Shot 2021-06-28 at 16.57.49

and is set to show:

I’ve looked but can’t find any setting that might be connected to pos not showing. Actually, I have several columns like this that should be displayed but are not. The are all “real” columns.

Would you say that this too is a candidate for, @Steve ? @aijac1314 , did you get any response from support?

P.S. I recall playing around with “Group by” in the early stages of building this app. I soon decided not to use the “Group by” function but I wonder if having played around with it in the beginning caused this issue.

I made a new table view from the same data. This time I am not using a slice and a avoided touching the Group by function. Still, only the virtual columns show up. :frowning:

Sorry for posting several times in a row. I’ll make this the last one.

Another odd thing is that the app seems to be making room for the columns that it is not showing:

If they were to be hidden for some reason, this shouldn’t happen.

I’ve started having issues too. The Group By is picking up the incorrect column. I’m grouping by a column called Group and its grouping by Product Code instead.

1 Like

Seems to have fixed itself. closed the Editor and opened it again and seems ok now. #MondayMorningBugs