Table View - Multi-Select + Actions

I have created a view of type table. At the top of the screen a multi-select icon is available, When items are selected, actions are shown that can be applied to the selected items.

Question 1: How can I make it so that the multi-select option is NOT shown?

Questions 2: How do I control which actions are available when multi-select IS shown?

TIA for any assistance you can provide.

What do you mean by multi select option?

This may not help you but in the action tab on the associated actions you can set formulas and also show how they display. Overlay, Prominently etc.

@Jonathan_S by multi-select, @Erik_Meyer means this little guy:

Q1

There isn’t a way to turn that off - it’s baked into the system. Could be a feature request, but honestly that little guy is really helpfull… and now that I’m remembering, I think that was a feature request that we bugged the devs about forever. :nerd_face:

Q2

Actions are shown in the order that they “live” in appsheet - meaning the actions are listed (typically in the order in which they were created), and that order is what drives what actions are at the left side and ride side of the action space:

You can reorder the actions by turning on a toggle:

2 Likes

crazy, just learned something new :slight_smile:

2 Likes

It doesn’t show up for my Deck views. But those aren’t for everyone and everything.

If I remember right, I think there was an explanation once something like this:

  • It’s a “smart” control, and only shows up if and when there’s the capability of it being used. If there are no actions that can be run over all the rows being shown, the toggle won’t be shown.
1 Like

Seems something like that. Even though the only action it shows on my other views is the Delete action, even making that unaccessible does not deactivate multi-select. However, if the data being viewed is not allowed to be edited by the user, it will turn off. So, use that info as you will.

1 Like

Base your table view on a slice that has no actions attached to it.

2 Likes

1 Like

This did not work :frowning:
Actions appear to be tied to data tables, not slices. I added a slice for my table view that did not have the cells that the actions act upon and set that slice as the data source for my table. Multi-Select option is still present and the actions are still showing as buttons the user can press.

I really need a way to control what actions the user is presented with. The actions I have created so far are not for the users, but more workflow stuff that is done in the background. I know, use a workflow instead of an action, right? Nope - that causees the app to sync every time a record is accessed which doesn’t work for this use case.

So I’ll pose my questions again:

  1. Is there any way to defeat the default behavior of showing the muli-select control on a table where I do not want it shown?

  2. Is there any way to limit what actions are presented to the user when it is shown? This might even answer number 1 - if there are no actions allowed for multi-select, maybe it won’t show itself.

Edit the actions to be unavailable to users:

1 Like

Did you explicitly remove actions from the slice?

Then you should inhibit their display:

I’ll repeat the answer you’ve already been given: no.

Yes.

1 Like

Thank you @Steve, that was what I needed!

The slice method started working as soon as I removed the auto option for slice actions.

The appearance setting of do not display for the individual actions also worked, without using the slice. As I had guessed, as soon as the actions were hidden, the multi-select that made them accessible also went away.

Thanks again for your patience as I learn more about the platform!

2 Likes

I feel your frustration. I went through it, too…

2 Likes

so-say-we-all-gif-2

1 Like