Tables privacy

I need to make the data entry for each app user private, i tried to deselect the Share tab on the Security in Tables and choose Access mode as app user, but it is coming up with an error and app is not running.

My plan is publisher pro by the way, i need an app to be uploaded to google play and be used by everyone and each user can save his own data without sharing it…please help me!

Hi @George_Abdelnour. Table Access Mode is probably not what you’re looking for. That controls whose credentials are used to access the underlying spreadsheet: the app owner’s credentials, or the app user’s credentials? The majority of people want as-owner.

Instead, I’d recommend using security filters. You can add an email column to your table, then use a [Email Column] = USEREMAIL() security filter so that each user only gets their own data.

1 Like

Sorry, I just saw that you’re using a publisher plan. In that case, there is no mechanism for securing data. This article explains:

1 Like

Hi @tony , question related to this one. I’m going to use the Secure PRO plan (sorting that out right now).

The app has a form where the users need to input information. I noticed that I need to give the individual users editing rights on the underlying Google Sheet to accomplish this. The underlying spreadsheet has information of other users I don’t want to be seen.

How can I give users editing rights on the underlying Google Sheet without having the Google Sheet be searchable on their own Drive folder?

Thank you,

Hi @maiga. You don’t need to give your users access to your sheet. In fact, the most common case is that app creators do NOT share access to their sheet. See this article for details about controlling this:

Related to this is the ability to make your app users only able to access their own data in the app. This is done using security filters:


Hi @tony,

  • I’m requiring login
  • Under Users, I have the users accounts set up as “can use app”
  • On the Tables & Slices, I have filters on such as [email] = useremail() and I’ve confirmed that they only see their information.

If I don’t share the underlying Google spreadsheet with the user, the user can’t even open the app. This is the error:

Error: Data table ‘Heron Progress’ is not accessible due to: Google.Apis.Requests.RequestError

The caller does not have permission [403]

I must be missing something obvious?

Thank you very much,

@maiga Can you check to see if your table is set to access “as app user”? You want to have it as “as app creator”

1 Like

Fixed. Sorry for the silly mistake. I assumed that “app user” was the right setting. Thank you!

1 Like

Glad you got it working!