Template: Extra Line in Nested Tables

In Google Doc I build a PDF template with Nested Tables.

You can see some extra space above and under the nested tables.
I want to get rid of these extra lines.
I can’t delete them.
I can set the font size to 1 and the Line spacing to 0.06.
I can set the Cell vertical alignment to “Top” and the Cell padding to 0.
So in Google Docs they would disappear.

But no matter what I do, the PDF would look like this:

Adding @Phil

Here is the sample Template:

Note: these are 3 tables: 2 nested tables in 1 table. You can set the border color to black to see where the tables are :slight_smile:
Note: The empty row is not empty. It contains an expression in white font.

My goal is simple: I just want to put a grey border around the 2 nested tables.

1 Like

I assume you have set the cell vertical alignment to Top and removed Padding?

I think what i would do is set the borders of the outer table to white. This effectively hides it.

1 Like


Are these two the same table?

It looks like you have tables inside of tables?

I’m thinking it’s because you’ve got two lines on the left column and one (where the two rows have been merged) in the second column.

You’re correct. I think that’s what he meant by nested tables. In a template to be able to display columns of templated data, in many cases you will need to create an outer table as a container and then insert tables into each cell that the data goes into. Some blank examples below.

Basic 2 column table with a “child” 2-column table inserted into each cell

Same table with Padding removed (set to zero) for each cell of the outer table

See the space above and below the “child” tables. No matter what you do you can’t get rid of it. After playing, I think this is by design because if the table borders actually aligned, you wouldn’t be able to select certain cells.

Setting the outer table border to white color produces a look like this.

There is still spacing used up in the template by the outer table and note the gap between the two child tables.

1 Like

What happens if you delete the row under the

<<START>>

Shared with CloudApp

I can’t delete the second row. Because in fact it’s not empty :slight_smile: I have a Start expression in this second row in white font color. This expression produces empty rows to fill the page, depending how much “filled” rows I have above.

I added a sample Template and some additional info in my original Post.

1 Like

I was able to solve it with a funny workaround :slight_smile:
I had to put some text into the cell that I want to hide.
Now it will respect the font size. So If I set the font size to “1”, the outer cell disappears.
So I just put a space into the cell and set the text color to white.
Now it looks perfect.

2 Likes

That’s a funny workaround indeed, when I just read your post I was wondering why i didn’t have this issue when building my latest template, but then i realized all my subtables were wrapped around if and endif expressions, so that worked as the placeholder text, and when it’s printed by appsheet it dissapears !

1 Like