The ... app did not load successfully. Please...

(Springville Power) #1

The … app did not load successfully. Please contact the app creator.

Somehow AppSheet or someone added several new columns to my spreadsheet over the weekend.

Then the individual users were complaining about an error. The error states:

The … app did not load successfully. Please contact the app creator.

unable to fetch app definition: Error: There is a mismatch in the number of columns between the spreadsheet for Sheet1 and the table schema. The table has 28 columns but the schema has 25 columns. Please regenerate the table column structure. Error: The table … is not available Error: Data table ‘…’ is either inaccessible or empty.

I was able to figure out where the issue lied and fixed it but deleting the added columns. I regenerated and it fixed the error. I checked with my users and one still has the issue and the other doesn’t.

I’ve unistalled the AppSheet app on this iPad that has the issue and reinstalled. I’ve re-synced the app. I’ve restarted the iPad it is on. Nothing I do seems to fix the problem in iPad user 1’s specific app. User 2’s iPad had no issues once everything was regenerated and re-synced.

Suggestions?

(Springville Power) #2
(Springville Power) #3

Suggestions anyone?

(Springville Power) #4

Aside from the behavior already mentioned, it seems three blank columns keep getting added to my Google Sheet. I haven’t added them and am the only one with a login. I haven’t got any warning emails that my email has been hacked. It is giving my users the aforementioned error. The one constantly sees this issue and the other has been resolved. +AppSheet

(Springville Power) #5

For whatever reason, it has resolved itself finally. Both iPads are functioning normally now. I’ll continue to monitor the issue and post more should there be issues. Thanks