The same error of mismatch columns keeps comi...

(Ward Janssen) #1

The same error of mismatch columns keeps coming back even after regenerating the table. It also says that the table is not avaiable.

It looks as if Appsheet uses an other table even though the docID is correct. Someone knows what to do?

(Ward Janssen) #2

Could it be that it is getting to complicated with 107 columns?

(Ward Janssen) #3

After changing the table

and regeneration in Appsheet, the

error keeps saying that the table has one column more then the schema. It advises to regenerate the column structure, however this does not solve the problem.

(Ward Janssen) #4

There were no hidden columns or filters. I think too little data in a column. Or indeed rows and columns with a hidden space. Or datavalidation in rows without data?

I deleted columns and rows next to the data range to be sure they were really empty.

(Ward Janssen) #5

Even when I login with an other account and restart by adding the data table is keeps telling me that there is a mismatch, table has 103 columns and schema 104. And that it is not available or empty.

(Ward Janssen) #6

Even when I make a copy of the table and start a new App. Same error

(Ward Janssen) #7

Please, is there someone who can suggest a solution?

(Aleksi Alkio) #8

Please check that you don’t have any values in an extra column with blank header value.

(Steven Coile) #9

Consider deleting (not just blanking, but actually removing entirely) all columns you aren’t using.

(Steven Coile) #10

Make sure you have no hidden columns in your spreadsheet! Also, remove any spreadsheet filters.

(Ward Janssen) #11

Its so nice to have support. Finally the problem is resolved.

(Steven Coile) #12

What was the problem?