This formula worked a few weeks ago, but now ...

(Elisha Murphy) #1

This formula worked a few weeks ago, but now it will only pull up the first value. (1 for Regular Time). The other values won’t pull up. I tried to reorder them and no matter what order, it would only pull up the first one. Additionally, when I put the “Time and a half” first, it gave me a Parameter 3 error. I do have the column set as a number column. Any thoughts? Thanks, in advance!

=SUBSTITUTE([Rate], “Regular Time”, “1”),

SUBSTITUTE([Rate], “Double Time”, “2”), SUBSTITUTE([Rate], “Time and a half”, “1.5”),

(Reza Raoofi) #2

What column is set as number type?

(Reza Raoofi) #3

Also the above formula seems like a section of a larger formula; how come those SUBSTITUTE(…) functions are comma separated with nothing else before/after them?! The whole thing ends with a comma?!

(Praveen Seshadri (AppSheet)) #4

if it is a number column, I suspect you’d want something like:

SWITCH([Rate],

“Regular Time”, 1, “Double Time”, 2,

… )

(Elisha Murphy) #5

@praveen Thanks, Praveen! That worked.