Time and DateTime are displayed differently

Screenshot from 2021-08-25 15-27-47

[Clock In] is a Time column. The data in the spreadsheet is “12:38:00”
[Clock in Timestamp column. The data in the spreadsheet is “15/07/2021 12:38:32”

Why are they displaying as 2 different time formats? If it matters, they are both being written by an action using TimeNow() and Now()

Dont really want to have a add another column and use a formula to sort this.

1 Like

The Time shown in the Timestamp is just plain wrong. There is no such time as “00:38:32 pm”.

And of course the Time field format should include the “pm”. I assume you have “Ignore seconds” turned on

1 Like

Yes on that Time. Also tried turning that on for the datetime but it may no difference

I did quickly through a time into a virtual column below are the results. …

…Well, just as I was posting this, things seemed to have returned to normal!!!

Original Screenshot

Now Screenshot

1 Like

Yup the Appsheet fairies have been in and fixed it for me too :slight_smile:

2 Likes