Time format does not show seconds on phone

,

Hi, I have a problem with Time column formatting on a form field. I need the form field to display the format HH:MM:SS with an initial value of ()TIMENOW but editable by the user. All this I can get to work perfectly in the builder/emulator. However, when viewed on my phone the format is different and omits the seconds which are critical. When submitted the seconds are in the excel sheet but these need to have been entered manually by the user. Things I have tried:

  • toggling the Ignore Seconds option on and off
  • having no initial value
    Neither seem to work. Help/suggestions as to why this is different on the phone would be much appreciated. Thanks.

I suspect this is a limitation of the phone. My understanding is that time and date input in forms is handled by the operating system, not AppSheet itself: AppSheet asks the operating system to ask you what time and/or date you want. This theoretically provides the user with a familiar interface they’s seen and used in other apps.

Based on this understanding, and recognizing the validity of your use case, I encourage you to engage support@appsheet.com so they get a formal record of your need.

Thank you for your response. I have been in touch with the support team. I suspect you are correct though in which case even if I manage to alter the offending settings on my own device, I can’t really expect users to do the same. Is there any workaround you could suggest? I’m thinking change it from Time type column to Text and do a text to time conversion elsewhere (in the excel sheet maybe?) If so, is there any way of forcing an input mask/format (ie HH:MM:SS using colons) so users are consistent in their submissions? As this is related to a sport event they need to be able to input accurately but at pace. Any suggestions would be gratefully received. Thanks

Your idea is probably the best one. AppSheet does not offer input masking. You can convert input Text to Time with the TIME() function.

Have you tried a column of type Duration?

image

See also:

Thank you. I’ve raised it with the engineers who are working on a fix. In the meantime, if it’s of interest, I’ve used 3 sets of enum drop down fields to represent HH MM & SS. When concatenated into a single duration field separated by colons this seems to work and provides the used with an easy way of scrolling to select the values for each unit of time rather than typing and risking a formatting error. I tried using sliders which would have been preferable BUT I couldn’t get a single figures 1-9 to come out as 01-09 and the duration field would therefore not accept the MM & SS values. Unless there is a way to make sliders give 0# formatting…?

image

Thanks but I’ve tried this a couple of times with Numeric digits set to 2. Numbers below 10 still come out as single digit.

When concatenating the Number-type column values, wrap the column values in TEXT() to apply the column formatting options:

CONCATENATE(TEXT([Hours]), ":", TEXT([Minutes]), ":", TEXT([Seconds]))

See also:

1 Like