Trouble formatting a date field

Hey there,

For some reason I can’t format a Date field that I’m showing on a detail view.

Some background:
The Google sheet locale is set to Portuguese. In Google sheets, I can see the inserted dates appear in the desired format (DD/MM/YYYY).
In Appsheet editor, the Data table locale is set to the same language. In the app preview, the date itself also shows correctly as DD/MM/YYYY.

But, when opening the web app, the Date is showing as MM/DD/YYYY, which is not what I want.
I checked on three different devices and all show it like that.

I’ve tried using TEXT in different ways, without success. I suspect I am not applying it the right way. Can you help?

I’m currently using DD-MMM-YYYY on the formula:

TEXT([Updated on], “dd-mmm-yyyy”)

When testing the expression, it actually looks good.

But even this is ignored on the app preview (which still shows DD/MM/YYYY). And the resulting web app still shows MM/DD/YYYY :confused:

How can I solve this?

The device or browser itself must also be configured with the desired locale.

You cannot use TEXT() to format a column of type Date.

Then i completely misunderstood it. Because a lot of the examples in the article mention date formats and conversion.

How can I format the date then?
Now I prefer to have the month in short or long name (MMM or MMMM), instead of the double digit, just to avoid any confusion for the users.

Should i change the format on the source table (Google sheet) ?

Thanks. I was just reading the Locale support article and it mentions that. I’ll have to check my browser configuration.

Edit: Yap. I tested it with Chrome. Changed the setting under “Order languages based on your preference”, reload the app, and the date shows fine now.

But I can’t rely on this. I have no idea how the users have their browsers setup.

Is there a workaround that allows me to show the date in a pre-determined way?
I’ve seen CONCATENATE examples but when i tried it, it didnt work.

1 Like