Truncated column header in table view with Yes/No fields

As per the screen shot, I am trying to use a table view to show a table comprising a bunch of Yes/No columns. I can not find a way to force the columns to be wider so that I can read the headers.

This is particularly annoying as I wanted to use the QuickEdit feature to toggle any of the values

Is there any trick I can use to force wider columns?

1 Like

Hi! have you tried this??

2 Likes

Do as @stilllifemuseum says.

But also consider playing with the Display Name setting inside the column settings. Using this you can sometimes force a column to be wider or narrower by using a longer or shorter word.

2 Likes

Thanks to @stilllifemuseum and @1minManager for your suggestions.

I had played around with Column Width settings and the only noticeable change is to the width of the first column, the Yes/No columns stay the same width with the truncated headings. I did make sure to Save and Verify after each change which was another tip I found on here, but still it was only the first column which appeared to change.

I did also try adding a load of dashes after the column name through Display Name, but again that made no difference. I guess that it is already truncating a column heading which is ‘too long’ and therefore making it longer doesn’t help.

I don’t know if this is something specific to Yes/No columns, but obviously the data in such columns technically requires the least amount of space, so if widths are adjusting based on data alone, then I might be stuck with useless headings.

2 Likes

Note that sometimes when lookin at the App in a browser some UX element get stuck. Just try clearing your temporary internet files or try another browser

1 Like

I tried clearing browser cache (Chrome), using an incognito session and using a different browser (Edge) and it makes no difference.

I can of course adjust the column widths through the browser as a user, but that is not particularly convenient for a situation like this.

I’ve also tried on a mobile device (Android) and again the Yes/No columns stay narrow regardless of whether I’m in portrait or landscape orientation.

Other table views in the same app have wider column widths, without me doing any sort of tweaking, but they do not have Yes/No columns.

1 Like

Hi @1minManager ,

I also wanted to suggest a workaround but just wish to be sure if it is different from yours or it makes no sense to repeat the suggestion.

Could you please update by the display name property of the column do you mean the below setting. That is “Display” name under “Display” option

or the below setting That is “Yes/No display values” under Type Details

3 Likes

Brilliant @Suvrutt_Gurjar that worked. I assumed @1minManager was referring to the Display Name (alternative column header) which was a trick I had seen elsewhere and did not make a difference here. However I changed the Yes/No values to be " N " and " Y " and that works perfectly.

5 Likes

Good to know it works for you. Yes, seeing your posts that you were working on column name display settings, I wanted to suggest the values settings but wanted to be sure what @1minManager 's suggestion was.

Please do assign the solution to @1minManager, if he was also meaning Y/N values all along.

2 Likes

I meant the column name. But you’re right changing the data within the column would work too

2 Likes

Noob question:

Graham - I like the format of your table.
(Did not know you could have input in this format using Appsheet. I can see this table format being very useful).

Noob question:

Can this format be used to create a table to input numbers instead of Y/N values (like a timesheet schedule)?
(In my case tension forces of post-tension cables in concrete slabs).

Thanks.

Hi @Felix.P_Tong, this format is displayed automatically if you check the option for Enable QuickEdit (beta) within View Options


I have only used it for these check boxes, usually preferring to have tables for viewing rather than data entry, but yes it can be used with any (as far as I know) field types.

2 Likes

Graham,

Thank you for your prompt response.

However I am having a problem editing the cell on the screen.
I get the screen showing the table as you did, but when I click on the values I get sent to another screen instead of allowing me to edit the value in place.

(See image below)

I already:

1- Check on (Enable Quick Edit (beta) - as you suggested.
2- I get check boxes at the beginning of every line.
3- When I click on any value the check box is selected, but I am not allowed to edit the individual cells.

Any Ideas?

@matt

To edit in place in a view click on the icon with a pencil, not the checkbox icon

2 Likes