Truncated column

Can’t seem to untruncate this number virtual column, which began truncating when it became 4 digits long:

Things I’ve tried:

  • Setting the table format to Wide (screenshot)
  • Save & verify data
  • Removing the format rule setting the column icon (screenshot)
  • Clearing browser’s local storage

Try to save the table as “narrow” and then Save & Verify

Interesting, but no cigar, with narrow and post-save&verify, another 3 digit long column also truncates:

What happens if you remove icons?

Same thing:

Sorry… I mean all icons.

One general thought that might help,

The images look like they might be captured from the AppSheet emulator?

Remember, that it uses the smallest screen Form Factor. If none of your users have screen sizes that small then you may be fighting a non-issue as the display will likely be different on a larger screen.

A small thing to consider before spending loads of time on it!

Seems to be even worse without all icons, as all columns get truncated in narrow.

Narrow:
image

Wide:
image



I have table views set to scroll horizontally, so viewport size shouldn’t be an issue. Still, for reference:

Wow! Awesome dashboard!

I see how the truncation is problematic!!

I’d like to see if I can reproduce the issue your are seeing.

The Total Stops and FL Deliveries views, are they Table views? And the columns that are being truncated, what data type are the defined as?

Thanks!


Yes, both are table views set to Wide column width, and both truncated columns are of type Number. Numbers started getting truncated when they became larger than 1000.

I can’t seem to even get close to the narrow column widths you are seeing. Are there any special Type Details you have filled in?

I might suggest to create a duplicate of the view(s). Not from Copy but from a new view and see if the second view suffers the same problem. I have twice run into weird issues where creating a brand new view seemed to correct the problems.

Nope:

I don’t doubt deleting and recreating the views may solve the issue, because I have another view for a different table where I have a virtual column producing the same output and that one does not truncate. But then we’d lose the opportunity to understand whatever makes these views behave this way, be it because of something I did and can learn not to repeat, or because of some yet uncaught style exception that can be improved in Appsheet.

You are correct! Most just want to get the issue resolved and move on. I applaud your willingness to pinpoint the issue.

My experience does tell me that this will not be an issue that you or I can resolve. But maybe we can help pinpoint circumstances that contribute to the issue.

I do see that you calculating the values with a SUM() function. I’ll attempt to re-create that also. Is it possible to see the complete expression?

Also, are there any other column settings that may have been changed/turned on? Might as well cover all bases to try to get to the bottom of it.

@Filipe I tried to reproduce the same issue but I couldn’t able to see the same behavior. Would you please send an email to support@apsheet.com so we could investigate where the challenge is.

1 Like