Trying to create tabs with header column - but it is not creating the tabs?

Trying to create tabs with header column - but it is not creating the tabs?

My table has columns to have in my app as headers (for the tabs):

Page 1 header
Page 2 Header
Page 3 Header
Page 4 Header
Page 5 Header

In my table (data) i have each of these columns as “Show” type:

Then i have the category for all set to = “Page_Header”:

Can anyone see what is wrong with this setup?

Hi @Tiger,

Have you checked this 'Tabs " setting under UX --> Options?

1 Like

Keep in mind, too, that tabs are only present in form views.

2 Likes

Yes -

I have mine as virtual columns. Did you put yours in your data source? Would that make a difference? And I have " " in the app formula.

1 Like

If you put something in the Content like: Header1, that should be shown in form.

1 Like

Hi @Tiger,

I am sure you must have already done so but just in case not, I hope you have also set the "Tab "setting under UX -> Options -> Forms -->"Form Page Style " as well.

I mentioned it again because the picture shared by you shows the same setting under UX -> Views -->Forms --> View Options -> Page Style -> Tabs

There are "Tabs"settings at two places.
My testing shows that the one under option UX -> Options -> Forms -->"Form Page Style " is mandatory and prominant while the other one under UX -> Views -->Forms --> View Options -> Page Style -> Tabs is optional

Hope this helps.

1 Like

I was not correct. Actually even without the content being filled, as long as the Options in the UX sections are correct, it will show a default “Page1” as Page_Header name.

Seems this issue should be corrected via setting:

I have “Tabs” selected?

Then most probably, you need to set the show column Require? to OFF.

Ok. I tried that - did not work either… :shushing_face:

Please post a screenshot of the emulator showing the view that is not displaying the tabs you want.

Sorry… LAST TRY: have you check your Slice and ensure that all show type column are indeed have been included?

4 Likes

HAHAHA. So all my headers were at the bottom of the Slice - in order. GEEZ!

Thank you VERY much!

3 Likes

Well done, @Heru!

3 Likes