Unable to add/edit/delete row in table - Permission issue

I get this error message when i try to add to my table, which has the source of a .xlsx file on onedrive: “Unable to add/edit/delete row in table ‘Indstillinger’. → You do not have permission to access one or more tables in the app. Please contact the app creator to troubleshoot this problem.”

Adds to the table are allowed, and the columns i’m adding to have ‘SHOW’, ‘EDITABLE’, and ‘REQUIRED’ enabled. Clicking ‘View Source’ takes me directly to the onedrive .xlsx file, which anyone with the link can edit. I’ve tried a bunch of the suggestions given to people previously asking this question, but none have been working.

Hope someone can help me with this :))

Thanks for answering, both as app creator and app user, the same error still shows.

Are there any messages in the Info >> Errors tab of the app editor?


I recommend you contact support@appsheet.com directly for help with this.

For others… the Excel file was opened in another tab.


Hi, I had the same issue and whats the best way to overcome this ? We need to keep the other excel file open while building the application. Is there any solution to make this work ? Thanks.

@Rifadm817 As far as I have understood it correctly how Excel365 works, there is no workaround as it closes the connection.


Thanks @Aleksi