Unable to add/edit/delete row in table 'Underground Agreement Form'. → Value is not supported for this column type. Use objectValue instead. → Error 1235 in SmartsheetProvider retry: Value is not supported for this column type. Use objectValue instead

Not sure if this is a bug or what. Issue is its not telling me what “Value” is not being supported for whatever column type its pointing too.

“Unable to add/edit/delete row in table ‘Underground Agreement Form’. → Value is not supported for this column type. Use objectValue instead. → Error 1235 in SmartsheetProvider retry: Value is not supported for this column type. Use objectValue instead… → Error updating row(s) in Smartsheet:”

Please contact support@appsheet.com for help with this.

1 Like

Hello, I think the reason for the error is the following:

The column type in smartsheet is different from the column type in appsheet.

Verify that the option “limit to values ​​…” is not checked in smartsheet.

The checkbox was selected.
I unchecked it and still got the same error.

I then changed all the dropdown columns in Smartsheet into just text columns.
And made those same text columns “enum” types and still got the same error.

So the question is, can a column be labeled a “dropdown” or “text” in smartsheet, but labeled “enum” in appsheet?

Is that is what i causing the error?

You can also verify that this field is blank if you use formulas in smartsheet

Did you verify that you regenerated structure after saving the changes in smartsheet?

1 Like

Yup, no formulas being used in SMARTSHEET.
All formulas are in Appsheet only.

Also I did reach out to the support team as Steve recommended. They said they are also looking into it as well

1 Like

Ok after some digging I narrowed the problem down to the column that is giving me the issue. Its my email confirm column.

This column is tied to a workflow. When the user selects one of the options given (Email or Both), the workflow automatically sends an email.

I disabled the workflow and still getting the same error however.

But with that said, when I create rows and skip that email confirm column, the error is gone.

Any ideas?

EDIT:

Ok looks like I got it resolved. @Cesar_Hernandez was on to something.
The issue was In Smartsheet I had the “Email Confirm” column set as a drop-down with values in it.
In Appsheet I had that same column set up as an “Enum” column with values in it.
I changed the drop-down to text and the error went away.

1 Like

I’m glad you’ve solved it

1 Like

Had the same issue.
I also have a column in Smartsheet “Email” but the column type is “Contact List”.
I unchecked “Allow multiple contacts per cell” and problem was solved.

Remember to regenerate the column structure after doing this.

1 Like