Unable to launch app

I see a white screen with net::ERR_Failed Everytime I try to open my smartphone app. I am able to launch the app in the browser and everything works fine.

I tried reinstalling the application using the installation link, but the same screen appears.

What could be causing this ?

1 Like

It looks like a couple of you are having this same issue. I would send a message directly support@appsheet.com

Thanks @WillowMobileSystems.

I have followed your advice and I have sent an email to support.

We are investigating.

Is there any update to this error as a client is having the same issues on tablets?
Thanks

Whoops! Sorry I didn’t update here!

The fix is to clear the app cache, or reinstall the app if clearing the cache doesn’t work.

We believe the problem was caused by an Android update that Google pushed out.

1 Like

Thanks Steve.

1 Like

Thanks @Steve. We had to reinstall the App. Clearing the cache didn’t work.

I am having the same problem with several users this morning.
I have,
Cleared Cache,
Cleared Data,
Uninstalled Appsheet,
Re-installed Appsheet,
Reinstalled apps,
and still same problem. White screen
Works on some phones, but not others which have same date for last date for last Android security patch level

Hi. We found a fix for this.
Add another account to the phone (we are using Google Accounts). Login via that account, and then logout again, and then switch back to original user, and then remove the new account that was added, and everything works. Have done this on 3 devices now, and all 3 worked afterwards.

4 Likes

@praveen
This happend again after 1 week. We had to reinstall the AppSheet App (Android).
What causes that problem and how to prevent it in the future?

I’m somewhat unfamiliar with the root cause of this issue. Adding @Gil

@Gil looking forward to. Because if the Login Problems continue, using AppSheet in Business will become impossible. My clients already wonder if they want to continue with AppSheet.

I had the issue a few days ago, No devices where affected accept my own phone. I Just reinstalled the app right as soon as this issue popped up and couldn’t get rid of it for 5 minutes. The reinstall fixed the problem immediately. Did not clear anything, didn’t restart phone.

@Gil Since more people are having the same issue, here is some background:
I had a Sample Galaxy S10. Android was not updated. This randomly happened in the middle of the day while on the road. I didn’t make any updates to the app.

@Fabian @Jonathan_S,
Were you both seeing the same error code at the bottom of the screen, net::ERR_FAILED ?

Yes

1 Like

Yes

Thanks.
I wasn’t able to reproduce this issue, so I’ll have to ask a few more questions:

  1. Does the app has the “The app can start when offline” setting turned on?
  2. Are you starting the app from a shortcut? Or from the AppSheet app (the paper plane icon)?
  3. Would any of you mind if I try to reproduce this issue using your apps? You’ll need to go to https://www.appsheet.com/account/account#_tab_acctConfig and set the "Allow AppSheet staff to access my apps for support and maintenance?’ checkbox.
    Then let me know the app name and account ID.
  1. “The app can start when offline” setting is OFF
  2. A shortcut on the Android Desktop created when you tab on “Install App”
  3. appName=QualityGate-622224
    As soon as my client checks the “Allow AppSheet staff to access my apps for support and maintenance?” checkbox you can try it out.

@Gil. We now have enabled the support check box.