Unexpected change of rows in my appsheet

I have the following problem. My app have the next problem, i have multiple rows within multiple page in the excel sheet.
So, when i edit the only editable row (in every sheet, is the same). All my row are replace with the first line of each page on the excel and its stay like that.
Any solutions? this have something to do with the formulas in my excel sheet? because all of them are just math

It sounds like you’re trying to use AppSheet in a way it isn’t designed to work.

Hi Steve! Thanks for your answer.
In my best try of explaining myself, i want to add this.
The appsheet works well at first, with 2 or 3 pages of the excel. You use the app to change the values of any row and all works perfect. BUT it seems like it has a problem with a 20 page excel, and formulas are located in diferent cells than the rows and colums showed and editable in the app.
Any sugestion in how to expose better this problem?
Thanks, for the answer.

AppSheet does not support inconsistent formulas, meaning all cells of a column with a formula must have formulas of the same format, and that formula format must be configured in the AppSheet column. You cannot mix formulas and raw values within a single column. You cannot use spreadsheet formulas in columns that aren’t configured in AppSheet for spreadsheet formulas.

AppSheet does not inherently support the idea of only one editable row in a table. To have a table with only one editable row, there is significant configuration needed in the AppSheet app. Attempting to enforce only one editable by any other means is very likely to cause problems.

My guess is this is a spreadsheet formula problem, unless you have actions and possibly workflows or reports setup to do this. Do you?

AppSheet is not designed to work with this type of spreadsheet design.

I don’t work with any workflows or reports setup, so far.
i made an honest mistake on my description. i have only 1 editable column (not row) of the spreadsheet, meaning 1 editable “value” on my appsheet.
I have to put formulas in other excel cells because the app have me showing errors when some formula wasn’t true. So i set, for example, in B2 “=I2” and I2 something like “=SUMA(Hoja2!A1:A4)/G6)” because when i set the formula in B2, the app dont show any type of data.
Should i try create a virtual row where i locate this math formulas?

1 Like

I’m a little confused now. Could you restate your problem with “row” and “column” used accurately?

I dont understand “Excel page(s)” at all. Not sure what it does mean.

1 Like