Update permissions

I’d like to start this little tip with a quiz. It you can figure out the answer to the quiz right away you don’t need to read on:

TEST QUESTION (10 points)

Joe had set his table permissions to “Allow updates”:

But, when he tried to add a “quick edit” to a view based on this data he got this:

The warning says the source doesn’t allow updates but Joe was puzzled because he thought he had set the permissions to allow them. What might have caused this problem?

Answer (click on the blurred letters to view):

The UX is based on a slice (which is based on the main data table) that has separate permissions.

More information

This happened because I forgot why I had designated a table to allow updates and made it “read only” to try to speed up my sync time. Then, I realized that I needed to be able to update it and tried to revert it to allowing updates. What I didn’t anticipate, however, was that the permissions on the slice would be changed so, in order to get back to where I was, I needed to fix the permissions on both the main table and the slice.

Here’s a little request for AppSheet: Could the error messages be tweaked to help users like me figure out that they need to check the permissions on the slices too? The phrase “data source” didn’t help me much in this case. It would be even cooler if the editor would tell me immediately (even before saving) that I’m not allows to set column to quick edit because of the permission issue.

2 Likes