Updates on the card view

Hi @Suvrutt_Gurjar thanks for sharing these examples, you’re not the only one experiencing this - those fields do appear to be ‘caching’ and not updating immediately, investigating now with the team.

9 Likes

Thank you very much @Peter.

The card views are powerful and can be very effectively used for say KPIs reporting dashboards, with real time updates,

4 Likes

Is it just me or are virtual columns not being updated in the Card View?

Hey Grant,

They appear to be working in my app. Can you send a couple of screenshots or describe the issue a little bit more so I can try to reproduce the issue?

Thanks!

Morgan

1 Like

You’ve got DM

Hi All,

Is there a release note or post about this update?

I’m having trouble figuring this one out as well.

@morgan
We can use an Address column as the image:


to get a map:
image

This is very cool.
Could you please extend this to XY columns?
This would produce an image without all the Google Stuff that we have right now:
image

9 Likes

That would be awesome!

The button seems to reset the template to a default status with all fields shown. But the button implies that there are backend changes and tweaks the AppSheet team are playing with for the layout aren’t being immediately pushed to end users in case it breaks things. The red dot would also imply there are pending layout updates waiting to be applied, but applying updates doesn’t make the red dot go away so there is no way to actually know if anything is actually changed or different.

I’m going to go through all my card views and click it, reset them, and save the app just in case there were some changes that are important, but I otherwise have no idea.

2 Likes

LMAO: one of the card view updates, changes the way they display inline on the emulator in “tablet” view:

Now, this doesn’t actually have any effect on anything. My actual tablets display fine. And the web browser preview does as well. So I’m sure this is just a weird bug with the specific “screen size” of the tablet emulator.

On the other hand, this really exemplifies the high resolution of these pictures. :rofl:

3 Likes

:laughing:

@Suvrutt_Gurjar After honing in on the “updating issue” @morgan and co. were able to isolate the issue and correct it. Mine is now working corectly.

4 Likes

Thank you for this excellent update @Grant_Stead. Thank you very much @morgan and team.This resolution of updating issue opens up many options of creating visually appealing KPI and other dashboards with card views. Thank you @Peter as well.

I will also try it now.

Please note of this update @Tony_Insua , @Lynn and @tsuji_koichi.

4 Likes

Hello. Great product you have here, just keeps getting better & better every time I come back to it to put something together. Except in the past week, a feature seems to have gone the other direction!

In CARD VIEW when an image field displays a percentage column, two weeks ago it would show a RADIAL PROGRESS bar. This was fantastically engaging for my use, and could even update offline. Turned green at 100%, life was good.

However last week, the radial progress aspect changed and now stays at 100% regardless of the value input, although without turning green as it did before. But the phone version still performed properly. Life still good, my users are almost exclusively using it on mobile.

Today, updating the phone version I found it has contracted the same issue. I found an awesome workaround some people are using through quickchart.io, but I dont believe it works offline.

Here’s a link to a sample app:

Heres an image of the radial progress bar error:

Any assistance would be very much appreciated!

Hey @APenADay – thanks for reporting this. This issue popped up when we made a few other improvements. I fixed this issue and it should be deployed ASAP (hopefully tomorrow). We also added more support for Price and Percentage types to the card view (you can now display them formatted in the text components).

Thanks and apologies for any disruption!
Morgan

3 Likes

Great response time, I dont know how you guys do it! Also just figure out that changing the column type to progress makes it work fine again. On desktop anyways havent checked mobile.

Thank you!

Nice @morgan !

Thanks for making tricks of quickchat alive!

2 Likes

Hi @APenADay - this issue should be fully resolved now. Thanks for your patience!

3 Likes

Hi @morgan could you make this possible? :slight_smile:

1 Like