URGENT, deadline approaching! This app I've ...

(Zachary Gatch) #1

URGENT, deadline approaching!

This app I’ve built to reflect somewhat of a PDF catalog is working through appsheet.com - The no-code app maker for Google Sheets, Excel, and more. Create mobile iPhone and Android apps for your business. Start for free and build powerful apps. and the emulator.

However, when I demo it on my iPhone and iPad, I get a return of alpha-numeric characters that signify there is a glitch in the process.

This action is by selecting my file to view which is using a direct URL house in a MS SharePoint site.

Any thoughts on why this is happening?

(Praveen Seshadri (AppSheet)) #2

I think the problem is that the URL you are providing is not for a PDF file — rather it seems to be for a web page that contains a PDF file.

What do your PDF urls look like?

Another option is to make the column a Url-type column — clicking on it will then launch the web page rather than trying to open it as a PDF

(Zachary Gatch) #3

@praveen, I need for this to be accessible when offline.

Therefore, I would need to go the route of the direct URL.

Is this correct?

Storing the files in Google, will still not allow for offline access…?

(Praveen Seshadri (AppSheet)) #4

ok, great. Glad you figured it out!

(Thomas Roberts) #5

@Zachary_Gatch1

You literally solved my biggest problem this week. I had the same issue. If its a reference table you need to make sure the Key is not on your shortest column.

(Thomas Roberts) #6

I cant thank you guys enough.

(Praveen Seshadri (AppSheet)) #7

Thomas, I don’t think that is quite right. It doesn’t matter if a key is short or not. What matters is that it uniquely identifies each row (i.e. no duplicates)

(Praveen Seshadri (AppSheet)) #8

Actually, if you want the content to be available offline, I would recommend storing the files as PDFs in Google Drive. Enable the AppSheet app option to have content available offline

and it should work fine

(Zachary Gatch) #9

@praveen, I thought dropping the files in Google Drive are only available when “online”…or is that when using the URL type (not a file type)?

(Praveen Seshadri (AppSheet)) #10

Images (Image type) and PDF files (File type) can support the Offline Content Caching option (Behavior -> Offline). If you enable this option, then this kind of content will be cached locally for offline use.

(Zachary Gatch) #11

@praveen, OK, so I’m up and running offline with PDFs.

But now I have 4 of my initial records not showing up in the app.

I have checked everything, but am unable to discern the reason for these not appearing.

Have you encountered this before?

(Praveen Seshadri (AppSheet)) #12

No. What do you mean by “initial records”.

To diagnose this, first go to the Table definition in your app editor and click on View Data. Do you see the rows there? If so, AppSheet is reading the data from your table but it isn;t’ showing in the app. Check if you have a Slice filtering out the data.

If it doesn’t show in the View Data, then it isn’t being read. Check if you have a lot of empty rows in your spreadsheet before the rows that are missing.

This article has useful tips. help.appsheet.com - App Changes Are Not Captured in the Spreadsheet or the App App Changes Are Not Captured in the Spreadsheet or the App help.appsheet.com

(Zachary Gatch) #13

@praveenI, 've gone through everything…even when I edit out to just create a change…it shows in the table def accurately, but does not reflect accurately in the app.

appName=SSIPresentationCatalog-187595

(Zachary Gatch) #14

I got it…it was the key.

When I selected the row label as the key, it displayed all records/row data.

Thank you @praveen.

(Praveen Seshadri (AppSheet)) #15

I’ll need a bit more details please Zachary. What are the steps in the app to reproduce the problem? What should I be looking for that isn’t there – what are the specific row values that are missing. Are the rows you’re looking for visible when you do View Data on the table?