Urgent help please! I have made an app that h...

(Marlene Williamson) #1

Urgent help please! I have made an app that has links to a personalized google map sitting as a public file in my Drive… An example link is

https://drive.google.com/open?id=1COYl-uNz2lBeq4odLCb3cpl3hZA&ll=-37.72071563603764%2C175.25619418156998&z=16

It has been working perfectly for nearly a year but last week, the links within the app no longer work - they open a web page with a 404 error saying it cannot be found. The link works when pasted into browser page on the phone,. the links work from the underlying Google Sheet, (https://docs.google.com/spreadsheets/d/1ZY9zAGBbS40beHk2jDN8MQLhgf54niC0scYBfVY8gWo/edit?usp=sharing) and the prototype visible in when creating in AppSheet also works perfectly. No permissions have changed on the phone.

I notice that the link when it appears in the browser is not the same as the link I use in the app - here are the two versions. The top one is one generated from the app on the phone, while the lower one is the actual link url stored in the underlying Google sheet.

https://www.google.com/maps/d/u/0/drive?state={“ids”:[“1COYl-uNz2lBeq4odLCb3cpl3hZA”],“action”:“open”,“userId”:"0"%7D&ll=-37.74909397599572,175.24659814704034&z=14 https://drive.google.com/open?id=1COYl-uNz2lBeq4odLCb3cpl3hZA&ll=-37.74909397599572%2C175.24659814704034&z=14

(Aleksi Alkio) #2

Is the problem only with some of the links or all of them?

(Aleksi Alkio) #3

How about Silverdale or Melville for example?

(Marlene Williamson) #4

Shared - and yes the link works perfectly in the desktop browser. Thank you

(Marlene Williamson) #5

Update…tried on another android device but same issue

(Aleksi Alkio) #6

I tried the app with two different devices… Samsung S8+ and Samsung Tablet Pro. S8+ worked fine with no problem but the Pro gave me the same 404 error message.

(Marlene Williamson) #7

Do you have any idea what might be happenning?

(Aleksi Alkio) #8

Brian is investigating this.

(Aleksi Alkio) #9

Can you set the Launch External option to TRUE.

(Marlene Williamson) #10

Done.

(Marlene Williamson) #11

@Aleksi_Alkio all of them

(Aleksi Alkio) #12

I copied two links from the spreadsheet you shared into a testing app and those links worked as they should. No 404 error or anything else. There has to be something broke in your app. What is the account ID and app name? If it’s okay I can check the app quickly.

(Marlene Williamson) #13

@Aleksi_Alkio

App name is

Streetscapes

and id 104518

(Marlene Williamson) #14

We both have OnePlus5 phones - mine is a 5T. Perhaps that is the issue

(Aleksi Alkio) #15

Have you tried with other devices as well?

(Marlene Williamson) #16

Not as yet as there are no other devices in the house. The app has been working perfectly on our phones until last week.i cannot see when the last system update was but Update log says sound notifications and sound in video instabilities fixed. No mention of any thing else

(Aleksi Alkio) #17

Would you please share the app directly with aleksi@1track.com so I can check the app with several devices, thanks.

(Aleksi Alkio) #18

Btw… is the link working correctly from the desktop browser?