URL Concatenate Question? Hi I am trying to ...

(Jim Davidson) #1

URL Concatenate Question?

Hi I am trying to use the URL option and cant get it to work with

=CONCATENATE(“http://ANameofawebsite/product/”,[Catalogue Number],)

The address is always the same it is just the Catalogue Number that changes hence using concatenate.

However the link will show in the app but it is not clickable. I have tried with Launch External and Is Hyperlink but still cannot make the link clickable.

Any advice please? Thanks

(Mary Jane Pender) #2

Gee, I wonder if it is a problem of punctuation Jim. I think you would need to remove the " that follows the / after product and put in a closing quote after the comma following the [Catalogue Number],"

.

That way the concatenated expression is now all encapsulated in the quotes. let me know if this helps.

m.j.

(Steven Coile) #3

The column should be type Url.

(Jim Davidson) #4

Thanks Steven I do have the column type set to URL. It shows in the app as a text link but it is not clickable.

(Jim Davidson) #5

@tony I thought I had it fixed but… I had url’s in the spread sheet that fooled me into thinking it was working.

Basically it seems that you cannot create a url from a concatenation that is clickable.

(Tony Fader) #6

@Jim_Davidson It’s definitely possible.

It looks like you have an extra comma in your CONCATENATE formula, as well. That might be related to the problem. AppSheet : mobile apps from spreadsheets : US National Parks - AppSheet appsheet.com

(Mary Jane Pender) #7

Not so sure now that my suggestion is right.

maybe just remove the comma after [Catalogue Number]

(Tony Fader) #8

@Jim_Davidson Can I take a look at your app? I’ll need the app name and steps to find the broken URL in your app.

(Jim Davidson) #9

@Mary_Jane_Pender Hi Mary Jane the string is correct, it renders in the app but it is not clickable. Thank you for your help.

(Jim Davidson) #10

@tony Hi Tony delivered3-562498 many thanks. Click burger menu the select manifests click edit and scroll down you will see the links display they are correctly formatted but not clickable.

(Tony Fader) #11

@Jim_Davidson Unable to follow your directions. I see a Manifest view in the center position of your app. When I click through the records of that view, I don’t see any URLs.

It looks like you’ve specified a custom column order for that view (Customers_detail). The URL column isn’t included in there. Maybe that’s the issue?

(Jim Davidson) #12

@tony Yes sorry Tony I moved things a little today. You are in the right place the “full Info” with the web site address is just above the image.

(Jim Davidson) #13

@tony Tony you were bang on I have solved this now thank you.