Using Row Filters in slices

I’m trying to show a slice of a table, and while the expression I have used, is correct, and in the test, showing the correct results, I’m still not seeing any data in my app. Is there a row limitation to the number of rows you can see in the app. My data set definitely has more than 1000 rows.

Could you please share the slice expression and possibly test results screen?

1 Like

Slice Expression:

and(
in([othgroup],Cons and Spares OTH GROUP[Consumable OTHGROUP]),
finyear = 2021
)

I have a mySQL table called product_master. From that table, I want to take all rows that follow the slice condition mentioend above.

Image is attached

Does this help?

There may be other issues but to start with, the correct syntax for using a column in an expression is [finyear] instead of only finyear. Could you make it as [finyear]=2021, if you are using [finyear] as a column value?

1 Like

Made this change. But in the app view, I’m still not seeing any data come up, although in the test, I’m still seeing information

Are there any test results with “Y”. The few in the screenshot are showing “N”
Have you tried to expand the test result and seen how each part of the expression is evaluating for a Y and N result?

In such cases, in general, a preferred approach would be to split the expression in parts and see where the issue is. One could try that in a VC.

1 Like

Let me try this, and get back to you.
Thanks!

So,
Slightly unrelated question. Am I not able to use external data sources unless I have an enterprise plan?

Could you elaborate "external data sources "?

If you mean cloud databases such as SQL Server etc. by this then yes one needs Enterprise plan.

1 Like

These are one mySQL database and one POSTgres DB hosted on AWS

1 Like