Using Webhook API to copy updated record to another table


I am using workflow rule to trigger Webhook so that i can copy the updated record to another table.
I have been following the instruction from this document:

However, the workflow rules did not copy the updated record to another table.
What could go wrong? Is there any sample app i can follow or any video tutorial which can help me solve this?

This is my JSON body template where i insert it in a google word that i created in “Body Template”.
“Action”: “Edit”,
“Properties”: {
“Locale”: “en-UK,
“Location”: “47.623098, -122.330184”,
“Timezone”: “Pacific Standard Time”,
“UserSettings”: {
“Option 1”: “value1”,
“Option 2”: “value2”
“Rows”: [
“Sewing Order Details ID”: “<<[Sewing Order Details ID]>>”
“SubCon": “<<[SubCon]>>”



I think you’re missing a comma

1 Like

MultiTech_Visions Thanks, that is a good catch.

However the webhook is still unable to run properly.

When i look at the Log of this workflow rule, it shows this error:
“Webhook HTTP post request failed with exception {“Message”:“REST API invoke request failed: Web API is not enabled for this application.”} The remote server returned an error: (403) Forbidden.”

What does it mean?

What plan do you have? It may be because that account is not a Business Plan.

1 Like

The app is still under prototype stage.

Have you enabled the API as described here

Yes i have enabled it.

That error is only reported when the web API is not enabled.
Is it enabled on the app that is the target of the webhook?

My web API is working fine now.

I recreate a new spreadsheet and start to test with one column which works.

When the Web API is successful to add data to the new spreadsheet then only i add the rest of the column to the new spread sheet.

1 Like

I get the following error with my webhook while trying to make an api call:
“Errors”: “Error: Workflow rule ‘On Change in Asset Protection’ ‘Body’ template properties could not be obtained due to Illegal characters in path. → Filepath contains invalid path character: Filepath argument ‘{ “Action”: “Add”, “Properties”: { “Locale”: “en-US”, “Location”: “47.623098, -122.330184”, “Timezone”: “Pacific Standard Time”, “Rows”: { “Customer”: “<<[CustNbr]>>”, “Status”: “<<[Status]>>”, “Timestamp”: “<<[Now()]>>” } } }’ passed to method ‘IdMappingFileProvider.translatePath’ contains an invalid path character '”’, ‘0022’. Error: Workflow rule ‘On Change in Asset Protection’ ‘Body’ template could not be read due to FileMimeType ‘’ is unexpected…",

It looks like you may have entered the Body template value into the Body Template property. The Body template value should go into the Body property. The Body Template property should contain the file name of the Body Template file, if you have one.

Hi @Bellave_Jayaram thank you for all your help on many posts of this community. Could you confirm if the rest API only works on deployed apps?

Thanks in advance!

I do not think so. To be sure, if it is not working in prototype mode for you, you can check with by giving details of your account and app. Good luck.

Thankyou so much for your answer @Bellave_Jayaram