Version number from AppSheet not supported for iOS

I whitelabeled my app for iOS. When I try to upload the IPA file on to AppLoader (XCode) -since is the newer way to do it, instead of iTunes- it gives me an error about the version number from my app which is not supported by Apple.
AppSheet generates automatically a 4-digit version number, like (12.1.3.6) but Apple only accepts 3-digit-version number (like 4.3.0). I can not see where this number comes from or how to change it.

At the same time, if I try to manage the version number in AppSheet (Manage/Deploy for iOS), to create a new whitelabel, AppSheet says I should only use numbers bigger than 9, and it gives examples using only 3-digit-version numbers… which then it automatically generates a 4-digit number…?? I don´t understand.

Thanks for any help.

@gil Any thoughts about this.

I tried to whitelabel a couple of times again and now it finally worked.

I changed the version number in AppSheet (Manage/Deploy for iOS) and manually set 9.0.0 as my version number and it uploaded well with AppLoader. I got a message from Apple to confirm it is now for revision in the Apple Store, and have to fix some errors, but now is on Apple´s side.

In the message I get from Apple Store Connect, my App is named as “My app name” 9.0.0 (12.6.0.2)
Both version numbers appear just like I wrote. It seems the 4-digit-version number is still in. Which I don´t know what does it mean. That 4-digit automatically created number was the one not accepted by Apple in my firsts attempts before I put 9.0.0

Sorry, I am not an expert. This is my first app.
Thanks for your help anyway.

Hi @Tarabot,
In your case 12.6.0.2 is the Build Version (CFBundleVersion), which is generated automatically by AppSheet. 9.0.0 is the Build Version String (CFBundleShortVersionString), which is what you put in the “Short Version String” field of the white label form in the editor.
I know this is very confusing, and you normally shouldn’t worry about it, but you can take a look at this post for an explanation on the differences between those 2 numbers:

I’ve looked at your white labeling submissions, and it seems like you left the Short Version String field empty in the first time, that’s probably why you had issues uploading it.

1 Like

Thank you for your reply.

I have another question:

In this post: https://help.appsheet.com/en/articles/962172-create-and-deploy-white-label-native-apps-for-ios

Says: If you hit errors with the Application Loader, please download XCode and retry using the included version. Note that it can take several hours between uploading the build, and that build being available in iTunes Connect. You can check the status in iTunes Connect by going into your app and clicking the Activity tab.

We are trying to upload the IPA to XCode but we cannot find the way. There is any explanatory post about how to upload the “Build” to XCode?

Thanks

@Tarabot,
Since the process of uploading your app to the app store is on the Apple side of things, it probably best to use Apple’s documentation. Here you can find a good overview with links to more detailed explanation on the different parts of the process:
https://help.apple.com/app-store-connect/#/dev82a6a9d79

In general, I think the whole process can be done using the Transporter app.

I hope this helps,
-Gil