Virtual Column calculates correct calculation but returning 0 value

Hi everyone,

I have a problem with a virtual column that returns the correct value when I test the calculation, however it does not display the values, instead only returning 0.

Here’s my virtual column:

When testing it, it actually returns the correct results:

But when i try to run it in the App UI, it is only returning 0 value:

Tried viewing it in the synced values but still, it returns 0:
image

Any help or tips would be appreciated.

Thanks in advance!

I would guess the Total Order column is a normal column rather than a virtual column. Both normal and virtual columns may have App formula expressions, but the big difference is when the App formula is recomputed. The App formula for a virtual column is recomputed frequently, including every time the app syncs. The App formula for a regular column is only recomputed when the row is otherwise updated, such as when edited in a form or modified by an action.

2 Likes

Hi @Steve!

Thank you for your reply.

I have two tables, OrderDetails and SalesDetails:

Total Order Column is a virtual column on my OrderDetails table:

Whenever the user was able to make one/multiple inputs on SalesDetails table, the “Total Order” virtual column should display the total order prior on syncing the form. I was able to get it running last time but now its not working anymore.

1 Like

@Steve,

I was able to get it running. What I did is make another virtual column of “Total Order” on the SalesDetails table, and assigned it on my AppFormula on OrderDetails “Total Order” virtual column, and that fixed it.

Thanks for the help!

1 Like