Virtual column is visible in mobile app preview but not when open in a browser tab

Hello friends, i have a couple of new virtual columns i just made and for some reason i can see them perfectly while previewing the app inside the editor, but when i open the app in a new tab i can’t see them, here are two pictures of exactly the same record in exactly the same view in each mode:

Also still having that issue with the colors of the dark mode constantly changing for some reason lol

Any ideas for finding my lost columns?

1 Like

Hi @Rafael_ANEIC-PY
What happens when you refresh your browser?

2 Likes

Hi @Lynn, well, the page loads again hehe, and there’s no change.

1 Like

Have you performed a hard sync within the app in the browser, using the sync button in the app? I’ve found the browser version of the app does not always (ever?) get the latest app version when the browser is restarted or reloaded. I find an app sync to be the only reliable way to get the latest app version in the browser.

Do you have a slice or security filter in place that might affect the browser but not the emulator in the app editor?

Is the content on the page? If you try to highlight it as though you were going to cut-and-paste, does the selection expose the missing text?

3 Likes

Hello @Steve, to answer each question:

I did, several times too, the only change im noticing is that im getting some weirdly fast sync times.

None that i know of at least, i have only ever used CONTEXT() for views.

It is not, there’s no space at all for that content, it’s like it doesn’t exist at all for the browser view, that would explain the improved loading times too i guess

EDIT: Went with the good ol’ chrome cache, history and cookies wipe and it works now, i really should just try that first everytime haha

3 Likes

Ouch! Well, at least something worked… :confused:

3 Likes