Virtual fields suddenly not displaying parent record data with Deref or Lookup

Hi everyone, I’ve been troubleshooting an issue where multiple virtual fields are not displaying their deref information. I changed the expression from a deref to a Lookup expression and still no data appearing. Its as if the child record (Collection) doesn’t recognize the parent (Route) REF field anymore.

Here’s what I’ve tried.

  • Tried LOOKUP expression vs. deref
  • Tried ANY() expression
  • Saved and verified the table
  • Regenerated the Table
  • Deselected/Reselected the Routes table from the child table REF field (caused a giant mess had to revert to a backup)

Note: Collection table route_id has no validations etc. - just the REF connection to its parent table Routes

image

At this point, I could really use a workaround until we figure out the problem.

Thanks so much

First and foremost: engage support@appsheet.com.

Please provide screenshots of the column configuration and the App formula expression for one of the affected columns.



1 Like

Are you sure [route_id] has a value?

Yes, there’s definitely a relationship in place as we can see the Routes associated Collection records. I double checked to see if there’s anything weird in the table and it looks pretty solid - data as expected.


1 Like

I’m at a loss. :frowning: Please engage support@appsheet.com.

Thanks Steve, sent the info over to support a bit earlier as well.

1 Like

Any ideas for a workaround - a way to get at the data without the expressions above?

None at all. If a) [route_id] is not blank and b) contains a value that matches the key column value in the Routes table and c) the referenced column itself has a value, I can think of no reason anything you’ve tried wouldn’t work. I have no idea what’s wrong or how to work around it.

Make it simple to display all field to work.