Webhook Not posting

Hey Appsheet team! I am having an issue with a webhook not functioning.
I have a workflow setup to send a webhook to Zapier (POST, JSON). I have 2 of these already set up and functioning on seperate workflows, just trying to add this for a separate form. The issue is that even though this is setup the same way, it isn’t posting to the zapier site. I have it setup with the zapier Url, Post, JSON, and then tried it with and without the auto-generated body template. I also tried an online webhook tester “webhook.site” and it didn’t pick up a response. I made sure the workflow was triggering by adding another action under the same workflow to email me, and it does.
Thanks!

What do you see in Audit History as described here https://help.appsheet.com/en/articles/962018-troubleshooting-webhooks

1 Like

Hi Phil, thanks for getting back to me.
Here is the error I got from the audit log. I’m guessing it has to do with syntax used in my column name, using “:”.

“Errors”: “Error: Failed to parse JSON due to Invalid character after parsing property name. Expected ‘:’ but got: s. Path ‘[‘Q2 Comments’]’, line 1, position 306… Invalid JSON value starts with: self-quarantine” by a medical professional?": “N”,“Q3 Comments”: “”,“Have you or any of your personn”,

Any idea how to fix this? Am I going to have to change my column names?

Well I ended up just removing everything I didn’t need via a text editor as the stuff that said was causing the issue was useless to me anyway, so now it works. :slight_smile:

1 Like

Glad you got it working. I just saw your earlier question.