Webhooks with API... If I have a url (API) for a table, do i have to use a webhook to push data into the table?

I am using an API with a public url. I do not have any trouble seeing the data in that API (url) table. However, when i go to add data from the app into that table - i get an error:

Do I have to set the webhook up in order to add data to the table?

Need more info.

  1. What API are you referring to?
  2. Where is the documentation for this API?
  3. Have you read their documentation?
  4. What is the endpoint expecting for Authentication and what are the required params/payload?
  5. Can you post a screenshot of your webhook config?
2 Likes

I have an API (url) built in json to bridge my app to another software. The only documentation i have is the url.
What’s expected (sample data that is in the table):
image

Screenshot:

Your webhook workflow is setup with a “Preset” that posts a webhook to appsheet itself. You’re wanting to post to an outside service it appears, you need to change those options, and enter in the URL endpoint yourself.

1 Like

Thank you - I am confused of the set up. Sorry.

So i changed this to:

And now i am getting this error:
image

This goes here, basically:

Like this?

That gives me the same error…

Probably wrap that entire Body expression in this as well:

{
"value": [
*existing body here*
]
}

As shown in your first screenshot from Postman.

Ok. I think this is right, but it still gives the same error:

Do you need that @odata.context field too?

Also maybe remove those HTTP headers, they might have just been held over from the appsheet preset, unless you need them? There’s no documentation for this API?

I can take the first part out and those headers.

And, no documentation. This is a guy that works here building the API using json.

Ok. A New error. It looks like it is reading the sample data in the API (Server) and not pushing my new entry:

image

I think it is trying to override the data already there? I guess I am confused. When i am dealing with normal tables (Google, Microsoft, etc…) I don’t use a webhook. Why do i need a webhook to put data into this table if i have the table set up as a Odata feed (API)? shouldn’t the add, delete, edit work regardless of webhook?

Hmm, yes, you are very confused…

OData connections are intended so you DON’T have to use API. I’m afraid I have zero experience using an OData source with Appsheet. How did your setup with that go? Did it test successfully, then got authorized access? Did you then add a new Table to your app from the OData source? It should presumably work exactly like any other Table added into your app. If you need to add data to it you should be using a “Data: add a row to another table…” Action. I’m also not sure if OData is restricted to certain Appsheet plans or not.

https://community.appsheet.com/search?q=odata

I have been using Odata for a year now. However, I have never written data in - READ only. Until now. I need to write data into the Odata (table).

Yes the set up is easy - i was thinking I had to set it up AND still do a webhook with the API.

So,
the Odata connection is fine. I see the data that was placed in there from the API (server) yet i cannot write any data into it?