When adding Open URL(Video) record disappears

I’m running into a very strange problem that I finally figured out how to re-create. I am trying to create a how-to section on my app that leads to a video how to. I am using the Card-Large option (but I tried switching it to Deck and can re-create the problem there as well). Basically, the cards will look like the following:


Then I want users to be able to click one of the cards and it open a video on how to do it.

I have created the videos, uploaded them to youtube, set them to unlisted (because I really don’t want them to be public as they have my app data showing) created a URL column for the link. Then in the Card I select where when you click on the card I have selected Open URL(Video). Everything works until I add this feature. I know the URL’s work because when I just show them as text in the card you can click them and they successfully take you to the youtube video. But the moment I select for it to take you there OnClick none of the records show any longer, it’s just a blank screen.

I’m pulling my hair out to figure out why it is behaving this way or I have found a bug? I tried switching to deck view. It will show just fine in deck view and automatically adds an action to go to the URL along with delete and edit. The moment I override and force it to only show go to URL all of the records no longer show anymore.

Anyone have any ideas or suggestions?

@Steve I noticed you have answers to a ton of the questions on these forums, any thoughts to what the issue could be here? Or have I indeed found a bug? :frowning:

I have no idea beyond the fact that card views are beta, so bugs should be expected. I don’t use them.
@morgan is the developer behind them; perhaps he can offer more.

Hi @LongingToProgram - there is a fix for this issue that will be released shortly, ideally by the end of the day on Monday. Apologies for any inconvenience.

1 Like

@morgan fantasic news! At least I’m not crazy. I can wait until next week no problem.

1 Like

Hi @LongingToProgram, this issue should be resolved. Let me know if it remains for you.

Thanks!
Morgan

4 Likes

Works like a dream now! Thanks

2 Likes

Sweet! Glad it worked out. I’ll be working on some more improvements / features this month. Stay tuned.

2 Likes