Where is my date format coming from? I hav...

(Nicholas Christoffersen) #1

Where is my date format coming from?

I have specified the Google Sheet:

File > Spreadsheet Settings > Locale:

Spain.

I have formatted all date columns in the spreadsheet as DD/MM/YYYY.

In AppSheet:

Data > Tables > Locale:

Spanish (Spain, International Sort).

In data entry forms, all dates are masked with DD/MM/YYYY – good.

But when viewing a date in read-only mode, on my computer the date still displays as MM/DD/YYYY.

On my phone the same date correctly displays as DD/MM/YYYY.

Details of my computer:

Mac, with locale set to Spain.

Yet the dates still display in MM/DD/YYYY on the computer.

Reproduced in both Chrome and Safari.

(Dinh Nguyen Nguyen) #2

@Nicholas_Christoffer Hi Nicholas, the datetime format in your app is also determined by the locale of the mobile device or browser that runs the app. Are you using Safari or another browser? If you run the app on a Mac but you don’t use Safari, you will need to change the locale of your browser to Spanish.

(Nicholas Christoffersen) #3

@Harry I am using both Safari and Chrome to test on a Mac.

Check out the 3 screen shots:

first is Chome on the Mac with the incorrect format.

Second is the correct format on my iPhone.

Third screenshot is of my Mac locale set to Spain and you can see the format of the date on the locale settings as DD/MM/YYYY.

The Mac is where I am having the problem (in both Safari and Chrome).

The phone is OK.

(Nicholas Christoffersen) #4

@Harry I performed further testing on a second computer, also a Mac, also with locale set to Spain, and saw the same problem persist on the other Mac.

(Dinh Nguyen Nguyen) #5

@Nicholas_Christoffer Hi Nicholas, could you check the locale settings of the browsers that you tested (Chrome and Safari)? It’s possible that the locales of the browsers differ from the locale of your computer.

(Nicholas Christoffersen) #6

@Harry Thank you, that worked.

I removed US English as a language in Chrome and Safari and replaced with UK English.

Now my display dates are formatting correctly, the same as the input dates.

It is still a little odd that there was inconsistency between a form for data entry and the display in a read-only view.