Why is changing the display order of a form n...

ux
(Aaron Blau) #1

Why is changing the display order of a form not an option like it is on detail and table views?

(Reza Raoofi) #2

This has been brought up a number of times; for now you can build your form based on a slice that has a custom column order.

You could also upvote the previously requested item in feature request app below; it is called “Customize column order in a form” https://www.appsheet.com/feature-requests

(Aaron Blau) #3

@RezaRaoofi

Thanks for your reply, that on the surface seems like a good workaround however how do I tell the program that I want to use the slice form instead of the default form? Do I need to setup three new views (one for inline, one for detail and one for form?)

(Reza Raoofi) #4

What behavior are you talking about? You mean the Even Action for that Form?

(Aaron Blau) #5

@RezaRaoofi

That is correct, the inline view currently displays all of the info, the only reason you would click it is to edit it, so I was hoping to save the user a click.

(Reza Raoofi) #6

Yea, I just tested it and you are right, it is unfortunate that setting Event Action for Row Selected to Edit will trigger the standard behavior of a Form with default columns order, therefore undoing the main purpose of such workaround. @Adam_Stone_AppSheet

Oh well, that was the only workaround I knew, so for now you will have to trade “an extra click” for “custom column order”! :wink:

However if the custom column order means excluding a few columns, you might be better off using Show_if to just hide those unwanted columns from Form view; that was the old fashioned way of excluding columns in Forms which also requires setting Apply show-if constraints universally to OFF in UX > Options page.

(Aaron Blau) #7

@RezaRaoofi

I appreciate the help either way.

(Aaron Blau) #8

@RezaRaoofi

A workaround to the latest issue with the incorrect form being displayed is to enable editing on the detail view. Click saved!

(Reza Raoofi) #9

In a simple scenario if you begin with a table view and build that table view based on the slice with custom column order, then the rest of the steps (i.e. Detail view, and Form view) of the selected row will be all inheriting the custom column order from underlying slice.

However if you were planning to have a custom view for an inline view, then it would be a little more complicated; you could make a new inline view based on the slice by referring to it inside REF_ROWS() function in a Virtual Column.

(Aaron Blau) #10

@RezaRaoofi

That’s a pretty large workaround for a UI inconsistency that doesn’t really make sense in the first place. Thanks for your reply.

(Marc Dillon) #11

@Aaron_Blau You are not the only one who thinks that.

(Marc Dillon) #12

Haha, I went to go upvote that feature request, then realized I made it in the first place…

(Aaron Blau) #13

@Marc_Dillon

Thought your name looked familiar :slight_smile: I upvoted it.

(Aaron Blau) #14

@RezaRaoofi

So I got it all setup only to find that setting the behavior on the inline view to open in edit does not open the slice form but reverts back to the original form. Is there any workaround to that?

(Reza Raoofi) #15

I just tested it myself to be sure, and it worked. Did you add a new Virtual Column with this App Formula? REF_ROWS(“SliceWithCustomOrder”, “ChildTable’sRefColumn”)

Or you just edited the existing REF_ROW() that AppSheet automatically creates? The latter could revert back to default formula with Table’s name, as opposed to Slice name.

(Aaron Blau) #16

@RezaRaoofi

I setup a new virtual column, I also setup new views.

It works as expected if I have the behavior set to “auto” on the inline form, it takes me to the new detail view and clicking the edit button takes me to the new form view.

However setting the behavior to “edit” on the inline view then reverts back to the old form view when clicking the inline record.

FWIW, clicking the new button instead of a line record takes me to the correct form in either scenario, so I’m confident I’ve set it up right.