Why the Len() Error when using it with or() or and()?

Hello all,
I was dabbling with len() while trying to create a [VirtualColumn] that checks if a [CertainColumn] has data Filled or Not.

So i simply created a virtual column, inputed this formula:
if(len([CertainColumn])<>0,“Filled”,“Not Filled”)
and voila its all good.

Then i decided to cross-check with a [SecondColumn] using this formula:
if(or(len([CertainColumn])<>0,len([SecondColumn])<>0),“Filled”,“Not Filled”)
and an ERROR: LEN function is used incorrectly"

What’s happening there? Is this a bug?

Notes:

  • When using the same column in the expression, it works. example: if(or(len([CertainColumn])<>0,len([CertainColumn])<>0),“Filled”,“Not Filled”)
  • Same thing happens with and()
  • I read somewhere that it might be a column type issue, so I tried changing the [virtual column] type to numbers and replaced the formula to: if(or(len([CertainColumn])=0,len([SecondColumn])=0),1,0) still same Error!
  • I know i can simply use this formula: if(or([CertainColumn]<>"", [SecondColumn]<>" "),“Filled”, “Not Filled”) to solve my issue, but the weird len() error is what im talking about

I would guess SecondColumn is not of a textual type.

image

Mmmm… Not really. :frowning: Read more:

https://community.appsheet.com/search?q=@steve%20quirk

Have you seen these?

2 Likes

isblank() does the job better, and true, my [secondCoulmn] was not text! My bad. Thanks :slight_smile:

1 Like