Workflow & Action Once Worked before the Google Drive Breakdown

workflow
bugs-issues-errors
#1
  1. Action updates the column value but not trigger the workflow

I have a grouped action to set value in column [if] & the others, which then invoking a saving file workflow:

IF([_THISROW_AFTER].[if]=4, [_THISROW_BEFORE].[if]=3, False)

It worked terrifically until 1 week ago (works before the Google Drive Breakdown).
Now the workflow not been invoked anymore, even the column [if] value is updated by the action.

  1. Action go google drive searching page, filtering the documents as wanted, works fine on Windows, but no more on iOX & Android (find no docs) since 1 week ago.

Any kindly ideas?

(Aleksi Alkio) #2

For the issue #1, you should probably use syntax
AND(
ISNOTBLANK([if]),
[_THISROW_AFTER].[if]=4,
[_THISROW_BEFORE].[if]=3
)

#3

[if] is an invisible and require column, has an initial value 1.

After checking the row content, managers can mark the progress([if]) via action buttons.

The most confused point is that this expression had worked for a while until 1-2 weeks ago. It seems that value change via action button cannot trigger workflow anymore.

(Aleksi Alkio) #4

Is it working now with the new version?

#5

I didn’t change the expression.
But I’d tried the following (don’t work):

Orininal-------------------
a GROUPED action button: changing values in some columns, including [if].
a workflow: a Saving File action via google doc template, monitoring [if] value.
=> It’d worked; now the workflow is not triggered as before.

Tried----------------------
a action button: just change [if] value.
a workflow: many changing value actions & a Saving File action.
=> workflow still not triggered even [if] changes.

(Aleksi Alkio) #6

Do you want to trigger a Workflow everytime when [if] column’s value is changed but the value is not “1”?

#7

No, depends [if] value; when [if]=3 & 4, triggered the different two “save file” workflows. (different templates for different progress and receiver)

I also tried the following workflow expression:

IF([_THISROW_BEFORE].[if]<>[_THISROW_AFTER].[if], [_THISROW_AFTER].[if]=4, False)

But still not triggered when it [if] turns 4 “via action button”. The workflow only triggered when I turn [if] visible, and “manually” make the [if] to 4.

(Aleksi Alkio) #8

If you use a formula as
AND(ISNOTBLANK([if]),[_THISROW_BEFORE].[if]<>[_THISROW_AFTER].[if])
it should trigger your workfow everytime when you update your “if” coloumn’s value with an action. Check first does it wor or not.

#9

I just tried. The workflow didn’t been triggered.

(Aleksi Alkio) #10

And what the audit history says for the reason?

#11

There’re workflow change records in audit history, but no file generated.

(Aleksi Alkio) #12

If you open the detail from that workflow, you are able to see has it done it’s job or not. And if not, you can see the reason.

1 Like
#13

It actually generates files, just under the later copied app B folder!

I copy apps, the original A is for desktops, the later B with simpler views is for mobiles, feeding them the same tables.

And there’s path assigned for Save File Workflow.

After B app copied, I remember that no matter which app is operated, once the [if] value changed, there would be two same files generated under each app’s folder (in the assign sub-folders actually).

We always search under the original app A folder… but now it seems to only generate file under app B folder, no matter which app operated…

My issue #2 is caused by this folder path mismatch too.

Sorry, I forget to search the whole google drive folder.

Is there any possibility to keep the workflow-generated-file under the original app A folder?

By the way, both the app have the same file upload feature, the uploaded files keep under the app A folder, none under app B.

(I bothered for this for a couple of days, thank you for saving me out.)

(Philip Garrett) #14

I am not entirely sure I understand what you are reporting.

Here is what I think that you are reporting:

  1. You have created two copies of your application. You refer to these two apps as “A” and “B” above.
  2. Both copies of the application contain a “SaveFile” workflow rule that is supposed to create and archive a PDF file.
  3. For each application, the “SaveFile” workflow rule is successfully creating and archiving a PDF file each time the workflow rule is invoked.
  4. The problem you are reporting has something to do with the folder where the PDF files are archived. It sounds like you are saying that both app “A” and “B” are archiving the PDF files to the folder for app “B”. Can you either confirm this or explain the problem more clearly?

I can investigate if you provide:

  1. Your account id
  2. The names of the two applications
  3. The names of the workflow rules.
  4. The exact steps to reproduce the problem.

Please make the repro steps very complete and clear. I will attempt to follow them and watch the behavior of the app in the debugger. This will almost certainly require that I add or update records to reproduce the problem.

2 Likes
#15

I made the first app PTI2-470892,

(1) Tables remain at:

GoogleDrive\

(2) User-uploaded-File reside under:

Google Drive\AppSheet\data\PTI2-470892\PTI\ (Project Name) \

(3) Workflow-PDF via manually value change

Google Drive\AppSheet\data\PTI2-470892\PTI\ (Project Name) \

(4) Workflow-PDF via the action button:

Google Drive\AppSheet\data\PTI2-470892\PTI\ (Project Name) \YSPO\

Then I copied the app, without duplicating tables, named it PTI6-470892.
These 2 apps almost the same, with the same workflow that can be triggered to generate PDFs.

After the copy, situation (4) changed. The triggered workflow, no matter operating at PTI2 or PTI6, would generate two same PDFs under:

GoogleDrive\AppSheet\data\PTI2-470892\PTI\ (Project Name) \YSPO
&
GoogleDrive\AppSheet\data\PTI6-470892\PTI\ (Project Name) \YSPO\

I don’t feel bothered by this change, though it would be better if just have 1 PDF generated under PTI2 folder.

About 1-2 weeks ago, situation (4) stopped generating PDFs to PTI2 folder, only to PTI6. (realize this after @Aleksi 's help)

I wish to understand what’s the difference between situation (3) & (4) and if there’s any possibility making situation (4) to generate PDFs under PTI2 folder.

Thank you very much!


(3) e.g. Workflow: PTI [F_Date] Doc_B
(4) e.g. Workflow: YSPO

===> I’ll record the screen later

#16

After several tests, I finally sure that user-uploaded-file always remains in the original data folder (PTI2), workflow-generated-file goes with which app that is operating (PTI2 or PTI6).

Both the file column and the workflow PDF have the same path setting to

PTI\ (Project Name) \ YSPO\

(Philip Garrett) #17

It appears that file uploads are being written to the correct folder. To understand where files and images are stored see topic “Image Storage in the Cloud” in this article https://help.appsheet.com/ux/capturing-information-in-forms/capturing-images In short, uploaded files are saved in a subfolder in the same location as the spreadsheet.

It appears that the PDF files are also being written to the correct folder. To understand where Save Files are stored see the three new articles I wrote today in the new section “Workflow: Create and Save a File”. The following article in that section should be especially helpful. See https://help.appsheet.com/behavior/workflow-create-and-save-a-file/save-file-archiving As it explains, that saved files are written to the folder specified in the “Default app folder” property specified in the Info > Property pane of the Editor.

If you want the PDF files for both applications “PTI2-470892” and “PTI6-470892” to be archived in the same folder, you should modify the “Default app folder” properties of both applications to be identical using the Info > Property pane of the Editor.

To make it easier to locate the file and folder name where the file is being saved, I have added the new property “FileName” in the AuditHistory record for the “SaveFile” workflow action. If testing goes well, that new property should begin appearing in the Audit History on the afternoon of Thursday March 28, 2019.

2 Likes
#18

Thank you so much. AppSheet genuinely makes our life much easier and with more possibilities. Tremendous Work!

Our app development is close to the finish line. Million thanks to AppSheet team!