Workflow Report expression

Hi,

I want to show a table in my workflow report only when certain condition is met. I tried to use IF() function, but it does not work for table. I can only use If function for the words inside the table.

Does anybody know if there is any solution to this?

Thank you

Hi @Jin_Tan Could you please expand on what you are trying to achieve.

Hi,

i am trying to create a workflow report with page. Workflow pagination, headers and footers.

But this table(Check the attachment picture)appears on every page. I want it to appear on the last page only.
Capture

What i was trying to do was using IF(condition, [insert the whole table], " "). However, IF() does not work for table.

Hi guys,

I solved it by reading this article. Thanks Appsheet team for this article. It helps. Yay:)

I was using <<IF([Condition], True, False)>> so it didnt work.

This expression in the link works.

3 Likes
<<Start: Submit 2 ID's Report[Key Timestamp]>> <<IF: AND(( 
Submit 2 ID's Report
[Needs to Submit 2 Forms of ID]= TRUE), ISBLANK([ORIENTATION]))>><< [2 Forms of ID]= TRUE>> <<EndIf>><<IF:( 
Submit 2 ID's Report
[Needs to Submit 2 Forms of ID]= FALSE)>> <<[2 Forms of ID]=FALSE>><<EndIf>> <<
Submit 2 ID's Report
[Still Needs to 2 Forms of ID]>>

Please help me I am getting Failed: Action not performed because 1 errors are present. Error: Workflow rule ‘Has Submitted ID Report’ action ‘Email Task’ Attachment template. Found 1 unmatched ‘Start’, 1 unmatched ‘End’, 2 unmatched ‘EndIf’. They are:

<<Start: Submit 2 ID’s Report[Key Timestamp]>> <<IF: AND((

', '

[Needs to Submit 2 Forms of ID]= TRUE), ISBLANK([ORIENTATION]))>><< [2 Forms of ID]= TRUE>> <><<IF:(

', ‘

[Needs to Submit 2 Forms of ID]= FALSE)>> <<[2 Forms of ID]=FALSE>><> <<

’, '

<>

.

Do you have an <<End>> tag for every <<Start>> tag?

Do you have an <<EndIf>> tag for every <<If>> tag?

Yes thats what is throwing me for a loop. Unless I am missing something. Please a fresh pair of eyes is highly appreciated!

This is my VC SELECT(Delivery Associate[_ComputedName], IFS(AND(ISBLANK([ORIENTATION]), [Needs to Submit 2 Forms of ID]= true), [2 Forms of ID]= true, [Needs to Submit 2 Forms of ID]= false, [2 Forms of ID]=false))

The template snippet you posted does not contain an <<End>> tag.

Please Steve thats not the issue

Sounds like you must know what the issue is, then.

And you sound really bored when I have a real issue so please stop