Workflow template margins

I’ve set up a workflow template Word document set up as Letter sized paper and landscape mode (in both the word document and AppSheet workflow settings). I am not using headers or footers.

The report it is printing is ignoring page margins. has anyone else experienced this?

As I remember, @Phil adjusted the workflow templates with “automatic” margins. So you can’t control it 100%.

I can ‘control’ the top margin by leaving blank spaces at the top of the page. But the bottom margins or subsequent page top margins are uncontrollable. The default margins are very low, see image:

There are two issues at work here. The first is Page Layout Settings. The second is Automatic Page Headers, Page Footers, and Page Numbering.

Page Layout Settings

In the Word Doc template, you can set:

  1. The Page Orientation to either Landscape or Portrait.
  2. The Page Width and Page Height.
  3. The Top, Bottom, Left, and Right Page Margins

When we convert the Word Doc into HTML, we honor these settings. The HTML body will include properties like the following:

body {
margin-top: 72pt;
margin-bottom: 72pt;
margin-left: 62pt;
margin-right: 62pt;
max-height: 612pt;
max-width: 792pt;
}

Automatic Page Header, Page Footers, and Page Numbering

We do not support automatic page headers, page footers, or page numbering.
I have expanded these articles to explain this limitation for fully.

For Google Docs see https://help.appsheet.com/behavior/workflow-sending-email/google-docs-templates

For Microsoft Word see https://help.appsheet.com/behavior/workflow-sending-email/microsoft-word-templates

1 Like