WORKLFOW RULE : CREATE TEMPLATE FAILS When c...

(Mark Krug) #1

WORKLFOW RULE : CREATE TEMPLATE FAILS

When creating a workflow rule to send an email with an attachment I can click on “Create” to create a docx template, but nothing happens. No docx template file is created: neither an email body template nor an attachment template. Any ideas? Tried different browsers (Firefox and Chrome), but still doesn’t work. Thx.

#2

Hi @Mark_Krug I think you will need to clear the file box to create a new doc.

(Mark Krug) #3

Thanks for your feedback @Lynn. So I cleared the file box containing the path/filename and tried “Create” again, but it still did not work. Having never created a template file for AppSheet before I was trying to generate an example file to see what it looks like and how the field names are tagged. Anyway I wasn’t able to generate one automatically by clicking the “Create” button, but I did look around other app examples and saw how it worked - easy enough. I then created my template manually, saved it in the appropriate appsheet/app/content folder then went and browsed for it in the workflow rule definition editor and viola! So automatic creation of the template didn’t work, but manual creation did. Another thing I learned along the way is that appsheet seems to not like to email attachment templates with headers (and footers probably). When I took the header out of my docx template and incorporated it into the body of the document then all worked fine.

#4

Thats great.

(StudentHomes Plymouth) #5

@Mark_Krug Funnily enough I’ve just discovered the same problem with headers & footers. AppSheet definitely does not handle them. I had a 14 page document with different 1st page header & footer then constant headers & footers for remainder. Everytime I ran it with AppSheet data it gave me my first page header on the second page and none of the others appeared apart from a footer on the last page.