XY column type!

Hi,

I wan to use a XY type and I am trying to use a image that I have in my google drive, and I try to use the URL of the image and nothing happens, what can I do to make it work?

It sounds that your image is not shared as “Public on web”.

1 Like

I still dont understand this… tried every thing i still get an error…

Your Google Drive files are typically protected from anyone with the link being able to access them. This protection is blocking the access to render the image for XY type (it has to be publicly hosted). To enable this on Google drive, try this - open sharing settings on the image in Google Drive. You can do this by right-clicking on the image and selecting “Share”. On the bottom, you will see an option to “Share link to …”. After you click it, you should be able to choose “Anyone with the link”:

2 Likes

CODE.
CONCATENATE( “https://www.appsheet.com/template/gettablefileurl?appName=PlotAllocatorApp-295153&tableName=Estates&fileName=”,[ESTATE LAYOUT])

RESULT

image

I have tried getfile… Not working as it behaves like a text type. The above is the closest but no image
please note that image and image folder are both public

Expected Result

So after much trial, I found a solution.
ERROR: Before now the referenced image was in a column set as column type IMAGE.

SOLUTION:

  1. Ensure your image is set as public on Google drive. (As explained by @kamila )
  2. DO NOT set the referenced column (column where your image is) as IMAGE. INSTEAD set that column as column type FILE.
    3.In your XY column, set background image as the column where the image is. Eg [ESTATE LAYOUT] or if from another table [ESTATE].[ESTATE LAYOUT]

This is the solution. And thanks to appsheet for making it simpler.

3 Likes

Thanks for following up with a solution!