Zapier API appsheet integration BETA

Anyone know why I am getting errors when I am trying to use zapiers beta integration with appsheet. The error is attached below?

Im not perfectly sure, but my understanding is Appsheet/Zap integration is no longer supported. It could be died out bata stage.

It is making sense to me (at least) as Google acquire appsheet (after this beta programme was in place), and Appsheet team should have been focusing on Appsheet Automation, which is their own integration tool to communicate the third party services.

Appsheet Automation (new feature, yet released) is competing with Zap, so my understanding is it is no longer supported, if i m not wrong.

Also Appsheet API requires Business Plans as well, which seems to be making story complicated as well.

3 Likes

can I use appsheet REST API in zapier to be able to add a new row to appsheet? if so how?

I m not Appsheet employee, only they could advise you precisely. Suggest you send your own query to support@appsheet.com

Again this is basis TBOOK (to the best of my knowledge).

I never used Zapier before on my production app of Appsheet, as I dont like to get the third party services involved, and make it my own rule to stay with appsheet features and function as much as possible for the Apps which I push and manage for my clients.

But I remember Zapier should have Webhook service in general.

Provided that the Appsheet account and creator is on the right plan to deal with AppSheet API, it should work.

Once you detect the changes in the data base (spreadsheet) then you take that even as trigger to initiate the subsquent job, which is to call to Appsheet API to trigger action.

See the document in terms of firing Appsheet Action through Appsheet APIs.

You set Appsheet action to change some value in some table. Then create workflow to do NOTIFICATION as you want.

I quickly tested with AppSheet/Postman, and the result was positive, so it should work, as far as we could make the settings on Zap correctly.

3 Likes

Hi @tsuji_koichi
I tried your method but I keep getting an error in zapier. Am I setting this up incorrectly? It says content type header missing but I have a content type header.

Content type should be set to JSON

As shown in the picture I have it set to JSON and I tried it again as shown in the image below. Still shows the same error.

As suggested , you go to support@appsheet.com as it is beyond my capability. Sorry.

1 Like

In the meantime are you on the appsheet business plan?

@tsuji_koichi yes I am

Sure, good luck with appsheet support then.

1 Like

Unbalanced quote:

image

Hi, I removed the quote and tried it again but still got the same error

Hi everyone!

Any news from anyone on the Appsheet staff regarding this? The problem is affecting our application too.

Regards

Please contact support@appsheet.com for help with this.

1 Like

@Phil is it true that Zapier Beta was discontinued? Was there an announcement? Maybe I missed it

I think this link should still work:
https://zapier.com/developer/public-invite/4368/597ae61fde8ebae08b865d92d46817be/

3 Likes

Hi Phil

Thank you for the response. The Zapier Appsheet integration doesn’t appear to work, I get the following error:

image

Is this perhaps the wrong version of the beta? This is version 2.0.3.

Regards

1 Like

Doesn’t seem to work.