Zebra scanner

I build an app for quarterly stock counting. It worked just fine in June on ZebraTC25 and ZebraMC33. Now in my new version of the app, only the ZebraTC25 works, the MC33 refuses.
First field in the form is a reference field (PartNumber) that is scannable. There is also a drop-down box active so you either can scan, or type or choose the number you want. Only know partnumbers can be scanned. Worked all just fine. No midifications have been done to this form or related tables. Problem is that the MC33 needs a ‘cursor’ in the field to be able to scan. (other fields in the form that show a cursor can all be scanned). However the first field does not show a cursor. When I tap the screen on the MC33 in the field PartNumber, no cursor appears. I can only scan in the ‘drop-down’ list. With the second similar field (ref/dropdown) of the ‘location’, same issue, no cursors appears.
Same app, different device = TC25, no cursor, but it scans fine! The TC25 also has a camera inside and AppSheet warns that the ‘camera must be active to be able to scan’, I switched that off because I don’t use the cam, but the scanner. Works. MC33 does not have a camera… I have looked into every setting I can imagine, makes no difference. I also have the older version still on the scanners, works on the TC25, stopped working on the MC33, no cursor. What am I missing? Has something changed? On my request we invested in several new scanners after our succesfull first stock count. Now same app, same scanner, but not functional. I have read every post I could find and google on SCAN and APPSHEET, but can’t find a solution or help. Would appreciate some feedback/help/possible solution.

Please contact support@appsheet.com for help with this.

I am also having issues with the MC33. Does anyone know how to resolve the issue of getting the cursor into the “search field” for text fields that have suggested values and to get the form to automatically save and advance to the next record? Note: I do have automatically advance form fields enabled.

Perhaps you might try changing that?

Hi Steve, I want the forms to advance automatically, hence having that option enabled. I have since figured out why it wasn’t automatically saving and advancing to the next record - I had forgotten to enable these in the Form view (palm meets forehead).

I am still unable to get the the cursor to automatically enter the “Add or search” field that pops up when I enter a text field that has a list of suggested values when using a mobile device (I have tested this on the Zebra MC33 android device and my iPhone). It does however work when using the web version of the app. It appears that behaviour mobile devices is different to the web version (including the preview/simulator displayed with using the app designer). Do you know how to fix this behaviour for mobile devices?

1 Like

Unfortunately, I do not. I seem to recall a bug similar to this. Given that, I encourage you to engage Support to report the unwanted behavior.

https://www.appsheet.com/Support/Contact