Action Condition LOOKUP not responding

Hello I have the following Condition placed on my grouped action and have used it many times but its not responding. I used quotes around “Administrator” as well. Is there another way to configure this?

Thanks

What does it say/show when you click test for the expression?

Try this instead:

"Administrator"=LOOKUP(USEREMAIL(),"Users","Email","Role")
2 Likes

Hi Steve, this worked for the action thank you. But here’s something interesting, I used “Administrator”=LOOKUP(USEREMAIL(),“Users”,“Email”,“Role”) on a form Show If as well to prevent visibility to an administrator dashboard but when I use the editor preview the non-administrator user or user not on the list can still see the dashboard - Eek! Is there an issue with Editor Preview possibly?

How do i secure this ?

For a form view?

Yes see below. I was using my Preview as option on my editor to test visibility by non-Admin users and got this view which should not have been visible. I’m starting to think the Preview As is not accurate as I changed my Role to Sales vs. Admin and saw what I expected to see with the appropriate restrictions. What are your thoughts on the Preview As functionality - reliable?


image

I can’t say, unfortunately. I’ve not had occasion to try it since the recent app emulator changes, and I don’t know if those emulator changes affected the behavior of Preview as.

A view’s Show if property only affects the view’s inclusion in the main menu and in the navigation bar along the bottom of the app screen. I’m not sure whether it affects a view’s display within a dashboard. It does not hide the view from direct navigation via URL in a browser, from display as a starting view, or display by an action or navigation within the app.

Where are you seeing the view that should be hidden?

1 Like

I’ve never been successful with the Preview As on the emulator.

1 Like