"app did not load successfully. Please contact the app creator."

I don’t have this issue on my computer, but it’s an issue on my friend’s computer when accessing the app, and he is signed in and already on the Users list with full permissions to edit the Appsheet. Is anyone able to shed some light on this issue within the emulator?
The error states,
“The undefined app did not load successfully. Please contact the app creator.”
&
“An asynchronous module or handler completed while an asynchronous operation was still pending.”

Screenshot:

I’m fairly certain it can’t be an app definition fetching issue, as this is the error in the editing mode’s emulator; and there are no new errors present under the Info section. Again, no issues with loading it on my computer, just with my friend’s account who has exactly the same authority as I do (in AppSheet) and successfully has had access in the past, no longer can get it to load on either of his two computers. No new columns have been added and while he’s able to edit things in the editor, the emulator still doesn’t load.

My Android device runs it just fine, as well as my Windows 7 laptop. We can’t get it to load on my friend’s Windows 10 machines, and thanks to recently finding this thread regarding the same issue (with more data than we were presented with), it seems likely a result of a Microsoft .NET update, or something similar that’s outside AppSheet’s direct control.

Try again it should be working now. They just rolled back an update that was causing the issue.

3 Likes

I still have the issue on the Windows 10 machines, but it’s morphed with the AppSheet Team’s recent slightly bugged update rollback that was completed about an hour ago. I’m still at,
“app did not load successfully. Please contact the app creator”
but with the sub-issue of,
“Unable to fetch app definition. Error:Object reference not set to an instance of an object.”

1 Like

Is this still a problem?

1 Like

Yes @Steve, it’s been resolved. Thank you!

tl;dr:
Resolved our tertiary problem by requesting and granting access to him under his own Google account.

Details:
After the rollback of yesterday’s update (at roughly 23:00 UTC, 16:00 Pacific Time), my error then became:
“Unable to fetch app definition”
&
“Error:Object reference not set to an instance of an object.”

I was unable to resolve it last night. This morning I woke up, retried and the error had changed again, and became:
“Unable to fetch app definition.Error: Data table ‘sample’ is not accessible due to: File not found”

This was ultimately an issue of permission to the Google Sheet by that particular user. While viewing within the editor-with-emulator, he could see the table was attached correctly, could click on the View Source button for that Table & it would open the Google Sheet, but we noticed the user on the Sheet wasn’t his (both users were signed into Chrome, the browser of choice, and could access their own AppSheet accounts, but only 1 had access to the Google Sheet).

Turns out the access he had in the past must’ve been with the other account signed in on the PCs. I recall helping him get going with a similar ‘did not load’ issue in which I copied and pasted my working url to his PC as a workaround and it worked. So the true issue went unresolved until now, when it slapped us in the face. :persevere: :clap:

1 Like