Getting Error while opening pdf

I am trying to open pdf which is created by automation and when opening giving error that’s file not found even I tried all given procedures and expressions by appsheet like pdf as well as HTML expressions for opening but problem exist and same error message not found getting. Pl guide me to how resolve this issue.

Hi @ashish_singh

Welcome to the commmunity !

The file column in your spreadsheet must indicate the relative path to the file in your drive.

Is the path file indicated in the error message, the same as the path where the file actually is ?


Yes I have checked it many times and path address is right.

Can you please share screenshot of

  • the pdf file path as it is in Sheets (written by the app)
  • the default app folder path ( App info/Properties)
  • the drive where the file is (including the file path part)

“?appName=”, ENCODEURL(CONTEXT(“AppName”)),
“&tableName=”, ENCODEURL(CONTEXT(“Table”)),
“&fileName=”, ENCODEURL([Voucher No.])

What i got message in page
I-1977’ not found
Probable cause: N/A
Path: Root
Message: N/A

Hi @ashish_singh

I don’t get it.

About your answers

  1. This:

It would be helpful to explain what it is and where you set this expression.
I guess this comes from this article, though I never used that kind of action.
By the way, as explained in this documentation, you would probably have noticed that you have to set the Security/Options/Require Image and File URL Signing disabled (maybe your issue ?)

Nonetheless, I’m interested into knowing what is the value of your column [Voucher No.], as it is my previous first question.

  1. This:

is the default path folder, if my understanding is correct ?

  1. This:

is the error message when you click on your action button ?

About my questions
These elements are helpful and I thank you for that, but these are partially the answers to my questions.

Another track to investigate:
If that may help, I suggest you have a look there:

1 Like

I also tried this-
CONCATENATE(“/appsheet/data/Receipts/ConsolidateSheet-4294788/“, [Voucher No.], “.pdf”)
Page is opening but getting same error.
[Voucher No.].pdf files are saving in my drive successfully but when triggering above action for opening from above values in filepath column getting error.

Voucher No. is key column of that table.

Can you show us the value in [Voucher No.].


this is not a file path.
Did you have a look to the thread mentionned here ?


I found problem now
info > properties > app properties > default app folder is = /appsheet/data/myapp-1234/
my googlespreadsheet is = /Myapp/googlespreadsheet
I change default app folder and it’s work:))

1 Like

That’s exactly why I asked screenshot in my 2nd post, we would have figured this out way quickly :wink: