Hello all! So I am a little bit confused at ...

security
(Miranda Lubarsky) #1

Hello all!

So I am a little bit confused at something that is going on with the app when I look at it on my computer as I am working “under the hood”.

The views that come up on the model app are very limited; I do not see all the views that I am suppose to see, even though I am signed into my gmail, etc.

And when I look at the app on my phone, I can see everything that I am suppose to see.

Needless to say, this makes it kind of annoying and difficult to work on the app, since I can’t see certain views unless I go to the UX and press a few buttons, and then it will let me see that view.

I have a feeling there is some way I can switch back and forth between views, but I’m not sure.

Many of the views have security filters for different crews, but I always make sure that I enable myself to see everything on my own account.

Thoughts? Many thanks!

(Steven Coile) #2

By “model app”, you mean the emulator in the app editor?

Please elaborate on “go to the UX and press a few buttons”.

(Miranda Lubarsky) #3

+Steve Coile Yes, I mean the app as it shows up on the right in the app editor.

When I go to the UX, and then the Views tab, and let’s say, for example, that I am currently unable to see the “2019 Construction Timesheets” view in the app editor.

If I open that tab up, and let’s pretend the View type is already Table, I will just click that Table button again, and the view will appear in the example app.

Once I click out of it though, it goes away and doesn’t show up in the app on the computer.

Including some screen shots for clarification.

(Miranda Lubarsky) #4

+Steve Coile

(Aleksi Alkio) #5

First try to clean your browser’s cache and see if that helps.

(Miranda Lubarsky) #6

@Aleksi_Alkio Omg it worked!!! You are the best!

(Aleksi Alkio) #7

You’re welcome

(Miranda Lubarsky) #8
(Steven Coile) #9

OK, it makes sense that the emulator displays the view when you click into the view’s configuration. The app editor always tries to display whatever view you’re actively configuring.

So the question is why doesn’t the view display as it does on your phone…?

My first thought would be something to do with your security filters. Are you confident you’re logged into the same Google account on both your computer and your phone?

(Miranda Lubarsky) #10

+Steve Coile Hey Steve, I’m pretty sure.

At the top, it says I am anyway (evelubarsky@gmail.com).

That’s the email that I use for app sheet.

(Steven Coile) #11

And on your phone?

(Miranda Lubarsky) #12

Yup, everything shows up perfectly on my phone.

It’s just the one on the computer that doesn’t show all that it should when I am editing

(Steven Coile) #13

Are you using USERSETTINGS() in your security filters? Perhaps a device-local user setting is affecting things?

(Miranda Lubarsky) #14

I’m not sure where to look for this, but when I go to Security>Security Filters, there is no expression in the Security Filter field, and all the Access Modes are set to “as app creator”.

(Miranda Lubarsky) #15

I just thought of something - does my email need to be on the “Approved Users Whitelist”?

Do I need to invite myself?

Seems like that would be silly, but just thought I’d ask.