HELP! All my apps can't run because of a data action no longer being valid

I opened all of my apps today…deployed and undeployed…and they all have errors that are keeping them from opening. All of the errors point to a “behavior” and all of them have the same “data action no longer being valid” but each app has a different data action(s) it references as no longer valid. All of these data actions are on the system level and some of them I can’t even find. please help

Did you try to refresh everything?

Please provide screenshots of the errors.

This is just one of my apps. I woke up to all of my apps having a message of this sort…just different actions. And btw- the “menuvalue” and “Menuchange” doesn’t exist. I’ve even searched for it…looked in system actions…etc. I think the weirdest thing is that all my apps had this error. Some of my apps I haven’t touched in a month or so.

Weird!

I would go to Info. properties. App Documentation. Click on the Here at the very bottom.

Once it runs, search that document for each of those action names. If they don’t exist in the documentation, I’d contact support. If they do exist, remove the references and see if that fixes it.

3 Likes

Thanks for the tip…I’ll let you know what happens

That worked. It doesn’t explain how it suddenly happened to all my apps at once…but I was able to fix it doing the application documentation search…thanks…I was so worried that my app was corrupted beyond repair

2 Likes

So glad it worked. Weird that it appeared in all your apps. Could someone have hacked your account?

Seems like a random way to hack me.

Bryan Coley
Chief Creative Officer
Reel Experiences

Hi Bryan,

The reason why your app broke that way is because we added a change to let users know their views were referencing invalid actions. Apologies that this caused frustration and confusion, I realize we didn’t provide enough of a meaningful error message so we’re adding that now.

We roll these things out carefully so we only enabled this change for a small fraction of our users. Sorry you got caught up in this. We’re fixing this rapidly so it doesn’t affect other people.

Maria

3 Likes

Perhaps making it a soft yellow warning rather than hard red error.

3 Likes

Thanks for letting me. It helps to know that it wasn’t something that had corrupted and might cascade to other things.

2 Likes