New Bug Encountered: Button Bleed when tapping a button on a Form

I have seen some unexplained navigation behavior for a while now and just recently realized what is happening. I’m calling this Button Bleed.

Basically when I have a Form open over the Main display and tap the Cancel or Save buttons in a spot that aligns with a Button underneath on the Main display, not only is the Form button activated but the that Main display Button is activated as well.

The video below will demonstrate this behavior (my first time including a video so if you have any issues with it please let me know)

If the quality is not good, you can adjust the Quality settings using the Cog button in the lower right-hand corner.

1 Like

Reminds me of that Post

Adding @Gil

Reported on June 17th (and I’ve only ever seen it on an iPad) I didn’t receive a response.

We have definitely experienced this same issue before on the iPad. I haven’t heard about it from my users in a while though so I think the issue may have gone away (at least for us). Please keep us updated if you get some kind of resolution.

Thanks for the video @WillowMobileSystems,
We thought we fixed this issue a while ago, but I guess it’s still happening at least for iOS devices.
I wasn’t able to reproduce this issue on my devices/apps. Would you mind if I try with your app?

No I don’t mind at all! Below is the app name and Account ID. Let me know if you need something else.

To be clear, for this problem to occur, the Main view button must align underneath the Form button.

appName = ServiceInsightBase-526414
Account ID = 526414

Ok managed to reproduce on an iPad, but not on iPhone. Which iPhone/iOS are you using?

iPhone 7 Plus with iOS version 13.1.3

FYI, I updated the iPhone 7 Plus to version 13.2.2 and the Button Bleed issue still occurs in the updated iOS.

Thanks @WillowMobileSystems,
We’ll look into it and let you know when we have a fix.

2 Likes

Just as an FYI, I have, since this posting, added a 6th button in bottom button bar that shows conditionally. This Button Bleed problem now happens almost every time I Save or Cancel on my main Form.

2 Likes

That’s strange, I tried again this morning (after you added the 6th view) and was barely able to reproduce it (maybe one out of 10 times). We’ll keep investigating.
@morgan

3 Likes

Ok, i tried again and if I simply tap with no awareness of where I am tapping it happened, to me, about 50% of the time. But, if I conscientiously tap in the same spot, I can make it happen almost every time.

Just make sure we are comparing apples, I am using an iPhone to test on.

To reproduce:

  1. Select a view on the far right or far left.
  2. Tap New to open the form.
  3. Simply tap Cancel.
  4. Note that at times the main view will switch to the “Attn” view - error.
  5. If error occurred, tap a view far left or right before testing again otherwise you won’t know if the error actually happened.
1 Like