New Bug Encountered: IMAGE DOES NOT SHOW ON THE APPLICATION

image
image

IMAGE DOES NOT SHOW ON THE APPLICATION??

@Igor @Aleksi

We have recently started moving our third-party services into google based. As part of it, our image serving layer originally hosted by Cloudflare is being migrated to Google Internal services. We started seeing some Quota issues from the internal services. We have increased the quota since then and it should resolve 403 GET calls. We apologize for the inconvenience.

3 Likes

Is this recently posted issue (Some(many) images not shown) is linked to this problem?

3 Likes

@tsuji_koichi yes, that’s the root cause.

1 Like

Thank you @Harsh_Ch
Well understood.

1 Like

Hi @Harsh_Ch

Over the weekend, our apps are broken in terms of rendering and saving images on some apps. I simply suspet this is related to this infra change you made recently.

We had a high resolutions images, which were saved and used as xy background (image file saved through appsheet app).
Until last week, it was working perfectly.

Let me recap the problem.

  1. Some high resolution image are UNABLE to upload newly to the app.
  2. Some high resolution image which has been saved (working fine) is not broken. Image not rendered on App.
  3. The app is failing to adjust the visibility, more clearly to say the resolutoin when we ZOOM IN on the xy type view. With those high quality images, upon zooming in on xy type view, it was showing the original quality (resolutions) nicely, but currently the image stay blur when we zoom in.

We reported to support desk just now, but just let you know.

We wait for bug shooting for this particular issue, thanks.

I suspect the new internal sysmte is failing to deal with high resolutions images as Cloudfare did for us.

@Takuya_Miyai

1 Like

For testing ,we saved the image file wihch failed to render on appsheet as well as failed to
save throug the app onto Firebase storage. Using public URL for iamge type as well as background image for XY, the image is working fine as expected. XY is showing original quality of image even after zooming in.

This tells us the problem for image is going from AppSheet server when we reach out to image file though AppSheet server.

1 Like

@tsuji_koichi looking into the image issues.

1 Like

Thank you @Harsh_Ch for your help
The image file this is saved to the folder through the image type column but failed to be displayed witihn the app has 19.4 mb file size.
Other smaller size images like 5, 6mb is displayed within the app, but when we use those file as background image for xy, the resolutions of image are blur, not clear as original file.

Additional suppoting informaition. We used Google Cloud Storage bucket as target folder to save those file for testing purpuse, to see if we will see the different results. It was completely save story as Google drive as image folder.

1 Like

I loaded google drive folder as table, and constructed public url for saved image.
Then this url is properly returned and image is shown within appsheet view. Furthermore, we could use this url as xy type background image. “Zooming in” is no problem in terms of resolution, retaining original high quality.

When we access to those file, through appsheet, it is triggering the problem obvisouly, based on our observation made through various testings.

1 Like

Is this problem already solved? the images in my app are still missing…

1

You are using wrong URL to display image using Google Drive file ID.

It should be

"https://drive.google.com/uc?id="&[GoogleDriveFileID]

Your URL is constructing download link.

1 Like

It has worked perfectly until two hours ago. I just try with a link of the image uploaded to firestore and the images remain broken.

This is not URL to your image saved in firestore. Just download link

1 Like

This link has been working until today. You can try open it on your browser:
https://drive.google.com/uc?export=view&id=1Yj1asyE_XTB00TmCjDoto_mJtAhcj8CB

I´ve also tried this one and the image still doesn´t appears in my app:

https://firebasestorage.googleapis.com/v0/b/appsheet-d9de4.appspot.com/o/Montaje%20PB%2FIm1-Tesamoll.png?alt=media&token=4a76516f-4970-41a2-a056-b3e06d4f67ce

Can you confirm if you can see the images?

Yes, it could see the image.
No idea why it is not showing in your view in appsheet.

We found the source of the problem, looking to get a fix released today.

4 Likes

Thank Adam. Now issue is solved.

1 Like

Thank you. Please let me know when the fix get released. I Can still not see the images.

Image is broken once again.
Back to the state when I reported the issue.